Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
0

No .csv and .eso output file from simulation

asked 2021-11-19 11:12:54 -0600

Mariha gravatar image

updated 2021-11-19 12:37:54 -0600

Hello to all, fortunately I managed to create a model without errors using sketchup and openstudio and I simulated it afterwards. I received various file formats, but no csv-format and no eso-format. However, if I simulate a sample file from EnergyPlus, I get these formats automatically. I have compared both IDFs (my own and the sample file) in the IDF editor, but cannot find any corresponding settings to the outout formats that are different. How and where can I set the output file-formats? Or do I need to change the source code to get the file formats? I am already a bit desperate and do not know how to look at and evaluate my results. Therefore I am glad about every hint!

(I have also tried the solution with sql and tableau. However, I do not know tableau and work mostly with excel.)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-11-20 08:36:20 -0600

lklawrie gravatar image

Have you added "Output:Variable" objects to your IDF. I would think there would be some option in OpenStudio to select output variables but I do not know.


Linda

FIBPSA, FASHRAE https://climate.onebuilding.org - free repository of climate data for building simulation Climate.onebuilding is a FREE service not supported by any outside organization or government agency.

edit flag offensive delete link more

Comments

Also make sure that, if you use OutputControl:Files, that the first field is "Yes"

Jim Dirkes gravatar image Jim Dirkes  ( 2021-11-22 05:05:28 -0600 )edit

If you select "Yes" for CSV in OutputControl:Files, it will use the native CSV output in EnergyPlus. You can still use ReadVarsESO (or -r in CLI) to generate CSV output from the ESO file, if you do not want to use the newer native CSV output.

MarkAdams gravatar image MarkAdams  ( 2021-11-22 09:03:41 -0600 )edit

Thank you Jim and Mark, I did so and put YES for CSV in Output control:files, but in addition I had to set the output control:table:style on comma separated. Now it works :)

Mariha gravatar image Mariha  ( 2021-11-22 12:33:42 -0600 )edit

The UnMetHours team wins another one!

Jim Dirkes gravatar image Jim Dirkes  ( 2021-11-22 12:49:14 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2021-11-19 11:12:54 -0600

Seen: 47 times

Last updated: Nov 20