Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
1

get error by upgrading docker image from nrel/energyplus:8.9 to 9.4

asked 2021-10-18 18:20:20 -0600

katsuya.obara gravatar image

updated 2021-10-19 08:58:23 -0600

I have been using energyplus docker image to run energyplus in aws.
I tried to upgrade docker image from nrel/energyplus:8.9 to nrel/energyplus:9.4 and updated corresponding idf file as well.
I could confirm that input idf file can run simulation locally using ep-launch but got following error when I tried to run using docker image nrel/energyplus:9.4.

ERROR: Input file must have IDF, IMF, or epJSON extension.

Does anyone have any idea what could be the reason and how to solve?

edit retag flag offensive close merge delete

Comments

I saw an edit at some point that showed the file, which is *.expidf. Rename to *.idf

Julien Marrec gravatar image Julien Marrec  ( 2021-10-20 04:46:06 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-10-19 03:05:54 -0600

updated 2021-10-20 04:45:46 -0600

The file you are trying to run... what is its extension? Because it must be idf, imf or epjson to work, as the message clearly states.

energyplus myfile.idf # Does work
energyplus myfile.something # Does not work
energyplus myfile.expidf # does not work
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2021-10-18 18:20:20 -0600

Seen: 54 times

Last updated: Oct 20