HeatPump:PlantLoop:EIR:Heating/Cooling model not heating or cooling

asked 2021-09-20 13:07:23 -0600

becker1212 gravatar image

updated 2021-09-21 14:58:46 -0600

I have been having some problems modeling an air to water heat pump heating and cooling system in energyplus. In the model, the HeatPump:PlantLoop:EIR:Heating and HeatPump:PlantLoop:EIR:Cooling objects serve water plant loops which have been connected to a Coil:Heating:Water object and a Coil:Cooling:Water object. These coil objects then serve a AirLoopHVAC:UnitarySystem that provides hot and cold air to the zones. I have the model in a place where it seems to be autosizing properly (the HeatPump:PlantLoop:EIR have not been autosized as I understand there have been some problems with that), however the zones are not being heated or cooled when the model is run. There is also no demand for the water loops even though the hot and cold water loops are available during the correct months. I have attached a zip of the idf and other relevant files for anyone to look at: HeatPump:PlantLoop:EIR Model

edit retag flag offensive close merge delete

Comments

@becker1212 you may be experiencing the same issues discussed in this post. If so, the next EnergyPlus v9.6 to be released soon should have a fix.

Aaron Boranian gravatar image Aaron Boranian  ( 2021-09-21 15:00:49 -0600 )edit

Hi Aaron, I have downloaded EPlus 9.6 and attempted to run the idf, but it is crashing energyplus. Is there a good way to debug crashes for E+ when it doesnt throw out errors? My first guess is it has to do with a misconnected node, but I'm not sure.

becker1212 gravatar image becker1212  ( 2021-09-29 13:41:31 -0600 )edit