Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
1

ReadVarsEso message

asked 2021-09-01 14:52:22 -0500

Aly ElHefny gravatar image

updated 2021-09-01 14:54:33 -0500

Hello everyone, I hope you are all in good health.

Currently, I don't have any reported items under "Output reporting" of the idf. And I've also selected all output controls files as : No. Still I'm getting the following lines at the end of each file run. (I'm losing some simulation time with the process corresponding to those messages appearing after my run): Requested ESO file=cs10.mtr ReadVarsESO program starting. does not exist. ReadVarsESO program terminated. ReadVarsESO program terminated. EnergyPlus Run Time=00hr 00min 39.04sec Is there a way I can overcome that ?

Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2021-09-03 12:15:38 -0500

If you have all OutputControl:Files set to No then EnergyPlus will not output a MTR file nor ESO file. The ESO file must be output for ReadVarsESO to function.

If performance is a concern, I would suggest using the native C++ CSV output instead of ReadVarsESO. To do this, you need to select Yes for Output CSV in theOutputControl:Files. If you use the native CSV output, you can keep all the files in OutputControl:Files turned off. One thing to note is to make sure you do not use the -r flag on the command line interface otherwise it will still try to use ReadVarsESO even if you've request native CSV output within the IDF.

edit flag offensive delete link more
1

answered 2021-09-01 15:23:47 -0500

Well, these don't hurt anything and should take very little time. But if you do want to eliminate this you can edit RunEPlus.bat in the root directory and either comment the problem lines out or come up with other logic for processing. I suspect it is the IF NOT EXIST lines that are calling ReadVarsESO.exe.

:  7&9. Run Post Processing Program(s)
if %maxcol%==250     SET rvset=
if %maxcol%==nolimit SET rvset=unlimited
: readvars creates audit in append mode.  start it off
echo %date% %time% ReadVars >readvars.audit

IF EXIST eplusout.inp %post_proc%ReadVarsESO.exe eplusout.inp %rvset%
IF NOT EXIST eplusout.inp %post_proc%ReadVarsESO.exe " " %rvset%
IF EXIST eplusmtr.inp %post_proc%ReadVarsESO.exe eplusmtr.inp %rvset%
IF NOT EXIST eplusmtr.inp echo eplusout.mtr >test.mvi
IF NOT EXIST eplusmtr.inp echo eplusmtr.csv >>test.mvi
IF NOT EXIST eplusmtr.inp %post_proc%ReadVarsESO.exe test.mvi %rvset%
IF EXIST eplusout.bnd %post_proc%HVAC-Diagram.exe
edit flag offensive delete link more

Comments

1

Also remember that you will never get any output in the future if you comment these lines out unless you remember to revert this.

rraustad gravatar image rraustad  ( 2021-09-01 15:26:01 -0500 )edit

Thank you so much for the useful information. Yes saving 3-5 seconds would result in major time savings for the scale I'm working on. It works for the normal energyplus simulation but unfortunately not for EP FMUs (export). Is there a way I can do that for FMUs ?

Aly ElHefny gravatar image Aly ElHefny  ( 2021-09-01 21:46:49 -0500 )edit
1

I am not familiar with the FMU workflow but there must be a call to ReadVarsESO somewhere in there at the end of the simulation.

rraustad gravatar image rraustad  ( 2021-09-02 07:07:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2021-09-01 14:52:22 -0500

Seen: 44 times

Last updated: Sep 03