Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

Possible bug in TimeStep in Openstudio 2.9.0

asked 2021-08-13 07:43:14 -0600

updated 2021-08-13 07:52:27 -0600

I have just notice that parameter Timestep in the OpenStudio settings is not being used in the simulation. For example, if I choose 6, this step is ok in the .osm file:

OS:Timestep,
  {210f49e8-ab04-4b81-b6fd-0fac6eeadcbc}, !- Handle
  6;                                      !- Number of Timesteps per Hour

But in the in.idf file it will always remain 4:

Timestep,
  4;                                      !- Number of Timesteps per Hour

Am I missing something?

I need to modify this value because I am using custom weather data with subhourly values. I guess the only workaround is to write a energyplus measure to modify this value.

edit retag flag offensive close merge delete

Comments

1

Do you have other measures in your workflow? I know that the Timestep object is modified by things like tariff measures that need a specific timestep interval for demand widows.

Eric Ringold gravatar image Eric Ringold  ( 2021-08-13 09:59:42 -0600 )edit

I would check what @Eric Ringold suggests. There was an old issue where GUI showed different default value than was used if not specifically entered, but that was fixed in 2016. https://github.com/NREL/OpenStudio/is...

David Goldwasser gravatar image David Goldwasser  ( 2021-08-13 10:26:31 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2021-08-14 06:00:24 -0600

Thank you very much for your comments. You were right. I was also using a tariff measure that was changing the timestep.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops

Question Tools

Stats

Asked: 2021-08-13 07:43:14 -0600

Seen: 112 times

Last updated: Aug 14 '21