Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
1

how to ignore data from design days in Python EMS simulation?

asked 2021-07-13 19:23:18 -0500

mechyai gravatar image

Hello, I am running simulations via Python EMS, collecting data for various analyses, and I want to ignore all the data during design day sizings. I only want to start collecting data once stuff has been sized and the experiment has begun. Is there a built-in way (ie. a flag) to know when the design days are done?
Or another workaround that is robust to various idfs and design days?

Thank you

edit retag flag offensive close merge delete

Comments

Perhaps it’s actually warmup days? https://unmethours.com/question/50320...

shorowit gravatar image shorowit  ( 2021-07-14 08:57:29 -0500 )edit

@shorowit thanks, I am currently already skipping warmup days with their method!

mechyai gravatar image mechyai  ( 2021-07-14 15:31:12 -0500 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2021-07-14 08:38:08 -0500

Is the Run Simulation for Sizing Periods field in the SimulationControl object set to No? Setting that to No may fix the issue you're having.

edit flag offensive delete link more

Comments

It is currently set to NO (everything else is Yes). Is this affecting my system sizing at all? I would like everything to be automatically appropriately sized by the sim.

mechyai gravatar image mechyai  ( 2021-07-14 15:30:28 -0500 )edit

What "calling point" are you using? Like on_begin_timestep_before_predictor, on_begin_new_environment, etc.?

bonnema gravatar image bonnema  ( 2021-07-14 17:44:10 -0500 )edit

@bonnema right now I am just using after_predictor_after_hvac_manages for testing, but soon want to find a good calling point(s) to get the zone 'state' and then actuate within the same time step, based on that 'state' for control purposes

mechyai gravatar image mechyai  ( 2021-07-14 21:24:00 -0500 )edit

You want the "Do Zone Sizing" field in the SimulationControl object set to 'Yes' if you have Sizing:Zone objects in the model. Same follows for the next two fields ('Yes' system sizing and 'Yes' plant sizing) if you have Sizing:System and Sizing:Plant objects (respectively). Usually if I am getting outputs for sizing days it is because the 'Run for Sizing Periods' field is set to 'Yes'. You stated the 'Do HVAC Sizing Simulation for Sizing Periods' field is set to 'Yes.' Maybe that field is causing the sizing day outputs? That is a new-ish (and optional) field. Try setting that to 'No'.

bonnema gravatar image bonnema  ( 2021-07-15 07:33:09 -0500 )edit

Setting 'Do HVAC Sizing Simulation for Sizing Periods' to 'No' fixed my problem, the simulation no longer runs for my 2 design days!! Thank you. Do you know if this impacts the autosizing of my HVAC tho? I am new to E+ and not completely familiar with the sizing calculations and autosizing process.

mechyai gravatar image mechyai  ( 2021-07-15 19:22:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2021-07-13 19:23:18 -0500

Seen: 102 times

Last updated: Jul 14