Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
2

help please, "No such file or directory @ rb_sysopen", error radiance

asked 2021-06-12 08:52:22 -0500

byroneme gravatar image

updated 2021-06-15 07:22:04 -0500

Hello i am using OS 3.1.0 and when i try to run te simulation with the measure of radiance the simulation do not run, with the next message:

Result: Fail
  Error: No such file or directory @ rb_sysopen - C:/Users/Byron/AppData/Local/Temp/osmodel-1623473679-0/resources/run/000_RadianceMeasure/radiance/options/treg.opt
    eval:425:in `initialize'
    eval:425:in `open'
    eval:425:in `open'
    C:/Users/Byron/AppData/Local/Temp/osmodel-1623473679-0/resources/measures/RadianceMeasure/measure.rb:736:in `run'
    :/ruby/2.5.0/gems/openstudio-workflow-2.1.0/lib/openstudio/workflow/util/measure.rb:515:in `apply_measure'
    :/ruby/2.5.0/gems/openstudio-workflow-2.1.0/lib/openstudio/workflow/util/measure.rb:114:in `block in apply_measures'
    :/ruby/2.5.0/gems/openstudio-workflow-2.1.0/lib/openstudio/workflow/util/measure.rb:67:in `each_index'
    :/ruby/2.5.0/gems/openstudio-workflow-2.1.0/lib/openstudio/workflow/util/measure.rb:67:in `apply_measures'
    :/ruby/2.5.0/gems/openstudio-workflow-2.1.0/lib/openstudio/workflow/jobs/run_os_measures.rb:70:in `perform'
    :/ruby/2.5.0/gems/openstudio-workflow-2.1.0/lib/openstudio/workflow/run.rb:292:in `step'
    :/ruby/2.5.0/gems/openstudio-workflow-2.1.0/lib/openstudio/workflow/run.rb:234:in `run'
    :/openstudio_cli.rb:971:in `execute'
    :/openstudio_cli.rb:761:in `execute'
    :/openstudio_cli.rb:1755:in `<main>'
    eval:175:in `eval'
    eval:175:in `require_embedded_absolute'
    eval:160:in `block in require_embedded'
    eval:154:in `each'
    eval:154:in `require_embedded'
    eval:113:in `require'
    eval:3:in `<main>'
  Info: Begin Encoding.default_external = UTF-8
  Info: Begin Encoding.default_internal = 
  Info: Radiance multiprocessing features are not supported on Windows.
  Info: Using 1 core(s) for Radiance jobs
  Info: Found Radiance at: C:\openstudioapplication-1.1.0\Radiance
  Info: Found Perl at: 
  Info: Found EnergyPlus at: C:\openstudioapplication-1.1.0\EnergyPlus\energyplus.exe
  Info: Radiance version: NREL 5.0.a.12 (by googs 2016.10.04) based on RADIANCE 5.0 Official Release by G. Ward
  Info: Radiance binary dir: C:\openstudioapplication-1.1.0\Radiance\bin
  Info: Radiance library dir: C:\openstudioapplication-1.1.0\Radiance\lib
  Info: Translating OpenStudio 2.x model to Radiance format...
  Info: OpenStudio CLI version: 3.1.0+82d3ea2978
Failed.

Can someone please help me. Thank you so much

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2021-06-15 07:37:41 -0500

measure.rb#L736: File.open("#{radPath}/options/treg.opt", 'r') do |file| is the line that's throwing, because the file does not exist. I'm not sure what went wrong though during the Radiance run. Are you sure your Radiance Daylighting Measure is fully up to date?

I have a test model locally that I just used on OpenStudioApplication 1.2.0 on Ubuntu 18.04, with the latest version of the Radiance BCL measure, and it worked fine.

edit flag offensive delete link more
1

answered 2021-06-16 15:52:27 -0500

byroneme gravatar image

Hi thanks for your help.

It is updated, the problem was that the mesh and the sensors were not assigned to the thermal zone.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2021-06-12 08:52:22 -0500

Seen: 459 times

Last updated: Jun 16