How to solve the Invalid blank Outside Boundary Condition Object for my case

asked 2021-03-22 13:53:02 -0500

Ahmad's avatar


I hope all of you are doing well and wish you the best always.

I've done my energy model in Openstudio and did the first simulation. I got a fatal error and the simulation stopped. Looking at the eplusout.err file, I have several errors which are like this:

" * Severe * FenestrationSurface:Detailed="SUB SURFACE 17", invalid blank Outside Boundary Condition Object * ~~~ * ...when Base surface uses "Surface" as Outside Boundary Condition Object, subsurfaces must also specify specific surfaces in the adjacent zone. "

I understand from previous questions asked by others that the outside boundary condition of a fenestration surface (sub-surface) must match the outside boundary condition of the base surface. If the base surface has an outside boundary condition object, then the fenestration surface will need one also.

When I go to the spaces tab, in the surfaces tab, the base surface for this subsurface is defined as "surface" in the outside boundary condition, see below surface 169:

image description

When going to the subsurfaces tab, this subsurface does not show an empty block in the outside boundary condition object (to the right) and I can't therefore choose anything, see below sub surface 17:

image description

I remember using the surface matching tool in sketchup and it was fine, but I don't know why Openstudio gave all these errors. Today, I started the surface matching BCL measure (Apply measure now) and it has been working for more than 5 hours now giving the page with the running measure circular arrow and no output. My model is 8 floors with 126 spaces including a lot of interior doors and exterior windows.

I hope you can assist in solving this problem and thank you very much.

edit retag flag offensive close merge delete


@Ahmad It appears the SketchUp Plugin's intersection didn't find or create that match.There should be an empty drop zone similar to surfaces but appears to be an issue with that. The Intersection method in surface matching measure doesn't attempt to intersect int sub-surfaces. Still, the surface matching measure should complete running. if you want to share your model here I can add that to our test models for some geometry method improvements we are working on. You may want to exclude interior sub-surfaces from your model unless critical, it isn't common and isn't tested as much.

David Goldwasser's avatar David Goldwasser  ( 2021-03-22 14:25:07 -0500 )edit

Thanks David for the reply ! Unfortunately I'm not able to share the model because of project restrictions, forgive me on that. I am interested to keep the sub -surfaces for some analysis. This error is repeated a lot so that means removing nearly all of them, but I really don't won't to do that. So with the surface matching not ending the run after 6 hours, what do you say ? How can I manually do that for the sub-surfaces ?

Ahmad's avatar Ahmad  ( 2021-03-22 14:42:20 -0500 )edit

"I am interested to keep the sub -surfaces for some analysis" - Are some of your zones unconditioned or partially conditioned and you are trying to model heat transfer between spaces? I could suggest making all interior surfaces adiabatic, but that would be more of an abstraction than keeping their boundary condition but just removing the sub-surfaces. Another suggestion is to try to make the manual assignments for sub-surfaces in the SketchUp Plugin's inspector.

David Goldwasser's avatar David Goldwasser  ( 2021-03-22 15:10:34 -0500 )edit

Thanks David again ! For the manual assignments of the subsurfaces in sketchup plugin inspector, how can I do that now after entering all my data in openstudio ? I go to the geometry tab and see my building but how can I access the sketchup from there ? If not and I have to do that from sketchup directly, how can I reenter the geometry in this .osm file that now has all my inputs (schedule, loads, HVAC, .. ) ?

Ahmad's avatar Ahmad  ( 2021-03-22 15:35:26 -0500 )edit

You can save and close the OSM file in the Application, Launch SketchUp, load your OSM make changes, save and close. Then re-open in the OpenStudio Application. To avoid problems just avoid having the OSM opened in both applications at the same time, as you may unexpectedly overwrite the file.

David Goldwasser's avatar David Goldwasser  ( 2021-03-22 15:45:16 -0500 )edit