Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
1

Transparency schedule is modified but it has no impact on the cooling loads

asked 2021-03-17 12:11:19 -0500

archammar gravatar image

Dear Community, I'm designing a dynamic shading system that changes hourly based on different shading states. I model the shading, as a context Surface with Shading:Building:Detailed and then I assigned a transmittance schedule with EMS to replicate the activation of the shading system. I have two sensors: solar radiation and operative temperature. I actually, followed the same method that was posted here: https://unmethours.com/question/37305...

I noticed that EMS is working fine, and the schedule is getting modified. But, it doesn't have an impact on the energy consumption results.

Regards

edit retag flag offensive close merge delete

Comments

As a check have you run the model without EMS once with shading surface schedule to 1 and the other to 0. This will confirm that the shading surfaces are impacting the model. An example where it might not be is if the surface normal is opposite of what is expected and if energy plus isn't mirroring them. Or the models zone surfaces may not be sun exposed or might be adiabatic and not have any heat transfer.

David Goldwasser gravatar image David Goldwasser  ( 2021-03-17 17:25:21 -0500 )edit

I have done a similar analysis with variable transmittance schedule and noticed the same thing so I posted a question. Within the question, you will find that there are two GitHub posts on the same issue but I am not sure if the issue is resolved!

Ammar De gravatar image Ammar De  ( 2021-03-18 02:18:06 -0500 )edit

Dear @David Goldwasser, Thanks for your comment. Yes, I did check as you mentioned. cooling loads is varying with shading transmittance schedule for 1 or 0. However, when I replaced the constant transmittance schedule of 1 with EMS object that has different values of transparency throughout the year, the cooling is the same as results obtained if it is 1. I think that the new transmittance schedule doesn't overwrite the constant schedule.

archammar gravatar image archammar  ( 2021-03-18 11:05:32 -0500 )edit

Dear @Ammar De, Thanks for your reply. Yes, I'm facing the same issue. Have you been able to fix it? I will look into these posts as well. Thanks

archammar gravatar image archammar  ( 2021-03-18 11:21:27 -0500 )edit

@archammar unfortunately not. It seems the author of this post was able to get the results he is expecting. So maybe you can read the post carefully and give it another try. Do you have any intermediate values for the transmittance schedule or is it just 1 (Transparent) and 0 (opaque)? I have a workaround in mind but I need to test it.

Ammar De gravatar image Ammar De  ( 2021-03-20 21:41:49 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2021-03-18 04:43:06 -0500

Andy Tindale gravatar image

There is a confirmed bug in EnergyPlus related to use of multiple semi-transparent shading surfaces reported here:

https://github.com/NREL/EnergyPlus/is...

I don't know if this is the same issue you are seeing and whether recent versions of E+ have been fixed. We have been advising DesignBuilder users to avoid using scheduled transparency.

Andy

edit flag offensive delete link more

Comments

Dear Andy, Thanks for your answer, I think it is similar to what I'm facing.

archammar gravatar image archammar  ( 2021-03-21 08:45:03 -0500 )edit
1

answered 2021-04-05 21:09:55 -0500

Ammar De gravatar image

As I mentioned in the comments, I performed a similar analysis with variable transmittance schedule and noticed the same issue, so I posted this question. Within the question, I referred to 2 GitHub posts on the same issue but I am not sure if the issue is resolved!

One work around that I can think of is to avoid using EMS since, it seems, is not working properly with transmittance schedules.

  • Instead, you can post-process your results by running the simulation once and reporting the corresponding output variables for the parameters used in the EMS control ruleset (i.e., solar radiation and operative temp in your case) and then come up with a transmittance schedule for every time-step of your simulation based on your control logic (assuming hourly analysis, you will have 8760 values for the transmittance schedule). Then you can use this schedule as an input for your model. Just in case you are running your simulation on hourly bases, you can use Schedule:File object to easily import your schedule from a .CSV file.
  • A simpler approach: since you mentioned that you were able to see that EMS is modifying your transmittance schedule then you can use this modified schedule directly as an input.

So Basically, the idea is to use the transmittance schedule directly considering the control logic rather than relying on EMS to do the job!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2021-03-16 13:17:48 -0500

Seen: 92 times

Last updated: Apr 05