Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
2

ResStock v2.2.4 end_use timeseries.csv not in data_point.zip

asked 2021-03-09 04:46:17 -0500

sashadf1 gravatar image

updated 2021-03-29 08:50:40 -0500

Using ResStock v2.2.4, OpenStudio v2.9.0 and EnergyPlus v9.2.

I am using PAT to run AWS cloud simulations. The issue is that end_use timeseries.csv is not showing up in my data_point.zip folder in the localResults directory after simulation has completed and I have downloaded all datapoints.

Here is an example data_point.zip folder open for data point id e5b3aed8-5a4f-4512-9a2c-f2a0cd5c3685.

data point.zip

As you can see, there is clearly no csv file in this directory.

My ordering of OS measures and reporting measures in PAT is below;

Ordering of OS Images

Ordering of Reporting Measures

An expansion of the Timeseries CSV Export measure shows I am NOT skipping it.

Timeseries CSV Export

Any idea why this is happening?

edit retag flag offensive close merge delete

Comments

Is it possible that the "Server Directory Cleanup" measure is deleting the CSV file?

shorowit gravatar image shorowit  ( 2021-03-09 12:17:47 -0500 )edit

I don’t think so because I haven’t edited anything in Server Directory Cleanup, nor have I touched that measure’s ruby code.

sashadf1 gravatar image sashadf1  ( 2021-03-09 12:25:56 -0500 )edit

Perhaps the CSV file is too large and getting excluded from the zip file. I think there is a maximum file size limit in OpenStudio. I can't tell how many output variables you are requesting, but you are requesting "Timestep" frequency, which could generate a lot of output. Perhaps try using "Hourly" or reducing the number of output variables.

shorowit gravatar image shorowit  ( 2021-03-09 12:33:46 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2021-03-12 03:14:54 -0500

sashadf1 gravatar image

The issue was that the CSV file was indeed too large. To decrease the size of enduse_timeseries.csv so that it shows up in localResults, you can either

  1. reduce the timesteps per hour of the simulation (if you are reporting under the timestep frequency) to reduce the row length of the CSV file.

This was done in measures Timeseries CSV Export and Set Residential Simulation Controls.

decreasing timesteps per hour in measure Set Residential Simulation Controls

reporting frequency timestep

or 2. turn off end_use subcategory reporting and include zero additional EnergyPlus output variables to reduce the number of columns of the CSV file.

This was done in measures Simulation Output Report and Timeseries CSV Export. no enduse subcategory reporting

no addtl E+ reporting vars

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2021-03-09 04:46:17 -0500

Seen: 24 times

Last updated: Mar 12