OS Sketchup plugin for Sketchup 2020

asked 2021-02-11 15:18:22 -0500

Ranjani gravatar image

updated 2021-05-06 13:47:28 -0500

Hi.. I am having issue with installing the OS sketchup plugin in SKP 2020. I have downloaded the plugin when i select the same using the extension manger, nothing happens and i dont see the path to os directory tab?

Can I get some help to resolve this?

edit retag flag offensive close merge delete

Comments

Are you trying to install 1) the legacy OpenStudio SketchUp Plug-in (works on IDF files, now named Euclid) or 2) the OpenStudio SketchUp Plug-in (works on OSM files). It sounds like you are trying to install #2 but you used the legacy-openstudio tag. If you are trying to install #2, can you share which version you are trying to install and operating system you are using? Can you deselect the OpenStudio extension, restart SketchUp, open the Ruby Console (Window->Ruby Console), and then enable the OpenStudio extension? Do you see any output?

macumber gravatar image macumber  ( 2021-02-11 23:29:33 -0500 )edit

@macumber I am using Sketch Pro 2020 and yes i am trying to download Openstudio sketchup plug in. I downloaded the plugin from this website - https://github.com/openstudiocoalitio... When i try to add this plugin to the extension manager it never asks me for root path and I tried entering the path in the ruby console - C:\openstudioapplication-1.1.0 i get syntax error. Can you please help me with this?

and is there a way I could still use this the existing plugin that i have in skp 2017 to switch between OS 2.8 and 3.1?

Ranjani gravatar image Ranjani  ( 2021-03-11 12:53:05 -0500 )edit

SketchUp 2017 uses Ruby 2.2.4 (OpenStudio <= 2.9) and SketchUp 2020 uses Ruby 2.5.5 (OpenStudio >= 3.0) so they can't work with the same version of OpenStudio. The 1.1.0 version of OpenStudio SketchUp Plug-in you linked to should be compatible with SketchUp 2020. Can you try uninstalling OpenStudio Application v1.1.0, installing OpenStudio Application v1.1.1-alpha2, and pointing the SketchUp Plug-in at OpenStudio Application v1.1.1-alpha2?

macumber gravatar image macumber  ( 2021-03-20 11:46:34 -0500 )edit

The OpenStudio Application v1.1.1-alpha2 solution worked for this issue: https://github.com/openstudiocoalitio...

macumber gravatar image macumber  ( 2021-03-20 11:47:09 -0500 )edit