Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
0

Help with Sketchup Plugin Install issue?

asked 2021-01-26 10:48:52 -0500

Ed May gravatar image

updated 2021-01-26 10:50:23 -0500

Hi all,

I am running into trouble with the Sketchup plugin installer? When I try and run it (either from inside the Sketchup Extension Warehouse, or by downloading the .rbz file and installing manual) it crashes Sketchup right away. Any thoughts on what I need to do to clean up the install to get it all working?

System Details:

  • OS: Mac OS X 10.14.3 on Macbook Pro
  • Sketchup: V.2019 - 19.2 (19.2.221)
  • OpenStudio Version Application: V1.1.0
  • OpenStudio Version: 3.1.0

When installing, the Sketchup plugin does appear to get successfully added to my Sketchup Plugins directory: image description

but then if I open Sketchup it all crashes right away. The only way to open Sketchup is to remove the 'openstudio' plugin files from the 'Plugins' directory. I would attach the error report .txt from the crash attached here for reference, but no .txt. uploads allowed here..... so: image description

More Details: It was all working perfectly. Then all of a sudden OpenStudio Application failed (was working away just fine, saved file, closed application, tried to open application again and it failed / crashed instantly, tried to reboot: same result). So I removed and reinstalled OpenStudio Application. Application is now working again, now Sketchup plugin is crashing on me after the OpenStudio Application reinstall (The plugin was installed before and was working perfectly before)

Any advice on how to sort out the Sketchup plugin install? Do I need to remove more than the files in the 'Plugins' directory in order to remove the previous installation? I can't remove from inside the Sketchup Extensions Manager cus Sketchup crashes on me unless I manually remove the files from 'Plugins' first? Appreciate any pointers anyone might have.

Thanks! -Ed

edit retag flag offensive close merge delete

Comments

If you have not yet try the 1.1.0 version of the OpenStudio SketchUp plugin. That fixed a mac crash.

Here is a link to the now closed issue for more background.

David Goldwasser gravatar image David Goldwasser  ( 2021-01-26 15:32:19 -0500 )edit

Hi David, thanks for getting back to me. Yes: the 1.1.0 plugin is the one that is causing Sketchup to crash when I try and install it. Whether I download from the github page:

https://github.com/openstudiocoalitio...

or if I use the 'Extensions Warehouse' to install, it crashes everything as soon as I install it.

thanks for the input though. best, -Ed

Ed May gravatar image Ed May  ( 2021-01-26 16:16:49 -0500 )edit

@Ed May while Unmet Hours doesn't allow direct file attachments, you could use a file sharing service like Google Drive, Dropbox, etc. and provide a link here so that others can see the error report .txt (or energy model input files, for future reference).

Aaron Boranian gravatar image Aaron Boranian  ( 2021-01-26 17:36:52 -0500 )edit

@Ed May updated information is helpful. It is good to know that it was working at some point and then stopped.SketchUp has preferences for extensions in a file that isn't deleted even when you un-install an extension. In your screenshot there is a file named "PrivatePreferenes.json" If you delete that it will remove information about many plugins, so don't do that, but we want to change it. I suggest making a backup copy before we change it in case we break the file. Open with a text editor and search for "OpenStudio": { delete lines through the closing bracket and comma },. Restart SU

David Goldwasser gravatar image David Goldwasser  ( 2021-01-27 17:13:43 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2021-01-29 21:32:09 -0500

Hi Ed, sorry for the problems. I think you are probably getting hit by a bug that was fixed in:

https://github.com/openstudiocoalitio...

Can you try installing the v1.1.1-alpha2 release?

https://github.com/openstudiocoalitio...

edit flag offensive delete link more

Comments

Hi @macumber - that worked great!! Thank you so much - I uninstalled OS App, reinstalled using the v1.1.1-alpha2, reinstalled Sketchup plugin from the Extension Warehouse, and now its all working again. Thanks so much!

best, -Ed

Ed May gravatar image Ed May  ( 2021-01-31 11:15:53 -0500 )edit
0

answered 2021-01-29 09:49:50 -0500

Ed May gravatar image

Hi @David Goldwasser,

Thanks so much for your advice - thats super helpful. I did as you recommended and tried to find every 'OpenStudio' case in the .json there. I removed:

image description

and then:

image description

and also:

image description

that seemed to work well and allowed me to get Sketchup up and running, and I could go to the Extension Warehouse and try and reinstall the OpenStudio plugin - that worked and I was able to get as fas as tagging the OpenStudio folder:

image description

but when I input the folder location (on my computer it is: /Applications/OpenStudioApplication-1.1.0/ ) it crashes on me. I get a 'BugSplat' report but no other information this time (no detailed crash report?)

image description

is there maybe another location that I need to clean out / remove in addition that you can think of that might be causing this?

if its helpful, this is a copy my current/edited PrivatePreferences.json file: https://www.dropbox.com/s/pyk2ui1ybks...

and my current Sketchup directory looks like this:

image description

any advice or other thoughts or recommendations you might have are much appreciated!

thanks so much,

-Ed

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2021-01-26 10:48:52 -0500

Seen: 224 times

Last updated: Jan 29