Missing required property 'construction_name'.

asked 2020-10-27 10:38:29 -0500

updated 2020-10-27 17:02:42 -0500

Hi, this is for a class project, and we are told to get help from here so here I am. So I was just building a simple geometry on FloorSpaceJS and imported on OpenStudio and set up some basic parameters. And when I was trying to run the simulation, an error occurred. And sorry it won't let me post an image, so I had to copy and paste the message below.

This is what I got when I clicked Run Simulation:

Initializing workflow.
Processing OpenStudio Measures.
Translating the OpenStudio Model to EnergyPlus.
Processing EnergyPlus Measures.
Starting Simulation.
EnergyPlus Starting
EnergyPlus, Version 9.3.0-baff08990c, YMD=2020.10.27 11:32
**FATAL:Errors occurred on processing input file. Preceding condition(s) cause termination.
EnergyPlus Run Time=00hr 00min  0.31sec
Program terminated: EnergyPlus Terminated--Error(s) Detected.
Failed.

Then I went into the eplusout file and found this:

Program Version,EnergyPlus, Version 9.3.0-baff08990c, YMD=2020.10.27 11:32,
** Severe  ** <root>[BuildingSurface:Detailed][Face 1] - Missing required property 'construction_name'.
**  Fatal  ** Errors occurred on processing input file. Preceding condition(s) cause termination.
...Summary of Errors that led to program termination:
..... Reference severe error count=1
..... Last severe error=<root>[BuildingSurface:Detailed][Face 1] - Missing required property 'construction_name'.
************* Warning:  Node connection errors not checked - most system input has not been read (see previous warning).
************* Fatal error -- final processing.  Program exited before simulations began.  See previous error messages.
************* EnergyPlus Warmup Error Summary. During Warmup: 0 Warning; 0 Severe Errors.
************* EnergyPlus Sizing Error Summary. During Sizing: 0 Warning; 0 Severe Errors.
************* EnergyPlus Terminated--Fatal Error Detected. 0 Warning; 1 Severe Errors; Elapsed Time=00hr 00min  0.31sec

So I guess the error comes from Missing required property 'construction_name'. But I couldn't figure out how to fix this. Can someone please help?

edit retag flag offensive close merge delete

Comments

If you go to the building tab there is a drop zone for construction sets. Then go to the Library tab at the right and expand out construction sets. Drag one of those construction sets from the library to the drop zone for your buildings, and then try again.

David Goldwasser gravatar image David Goldwasser  ( 2020-11-05 22:54:55 -0500 )edit