Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

Sketchup PlugIn Error

asked 2020-08-13 10:13:42 -0500

TheEnergyTutor gravatar image

updated 2020-08-13 16:45:04 -0500

Given the fact that the developer of FloorSpace.js says he doesn't intend to fix the pluenum door issues (documented here) am trying Sketchup but i get this plug-in erorr.

Does anyone know why i'm getting this error when i try to register the plugin? @macumber Everytime i try to install the plugin it wants to default to the 2.9 path, but i was able to reset it but it still won't do it right.

image description

Is it because i am using Make 2017? Because i see videos of other people using this and it working just fine.

https://youtu.be/WkgQAIaXy78

image description

openstudio_dir = Sketchup.read_default("OpenStudio", "OpenStudioDir") C:/openstudioapplication-1.0.1 openstudio_modeleditor_rb = File.join(openstudio_dir, "Ruby/openstudio_modeleditor.rb") C:/openstudioapplication-1.0.1/Ruby/openstudio_modeleditor.rb load(openstudio_modeleditor_rb) Error: #<loaderror: 126:="" the="" specified="" module="" could="" not="" be="" found.="" -="" c:="" openstudioapplication-1.0.1="" ruby="" openstudio.so=""> C:/openstudioapplication-1.0.1/Ruby/openstudio.rb:55:in require_relative' C:/openstudioapplication-1.0.1/Ruby/openstudio.rb:55:in<top (required)&gt;'="" c:="" openstudioapplication-1.0.1="" ruby="" openstudio_modeleditor.rb:67:in="" <code="">require_relative' C:/openstudioapplication-1.0.1/Ruby/openstudio_modeleditor.rb:67:in<top (required)&gt;'="" <main="">:in load' <main>:in<main>' SketchUp:1:in `eval'

Thanks

edit retag flag offensive close merge delete

Comments

1

Are you using the newest v1.0.1 of the plug-in? I fixed some bugs around this issue in that release. If you are in SketchUp 2017 you have to load OpenStudio from 2.9.1, that is because both SketchUp 2017 and OpenStudio 2.9.1 use the same version of Ruby (2.2.4). SketchUp 2019 and 2020 use a newer version of Ruby (2.5.5) that is only compatible with OpenStudio Application 1.0.0 or higher.

macumber gravatar imagemacumber ( 2020-08-14 01:12:15 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2020-08-13 17:39:03 -0500

The newer version of the OpenStudio Sketchup Plugin requires Sketchup 2019 or 2020. The user in that video is using Openstudio v2.9.1, which has the older version of the plugin which works in Sketchup 2017.

edit flag offensive delete link more

Comments

3

The OpenStudio SketchUp Plug-in rbz should work in SketchUp 2017-2020. If you load it in SketchUp 2017 you will have to point it to an install of OpenStudio 2.9.1. If you load it in SketchUp 2019 or 2020 you will have to point it to a version of the newly separated OpenStudio Application 1.0.0 or higher.

macumber gravatar imagemacumber ( 2020-08-14 01:10:15 -0500 )edit
0

answered 2020-08-13 12:58:41 -0500

updated 2020-08-13 13:11:51 -0500

It appears you are trying to install the Euclid plugin, not the OpenStudio plugin. You can find a link to the latest SketchUp plugin here: https://openstudiocoalition.org/

If you are trying to install previous versions, you can find them here: https://github.com/NREL/OpenStudio/re...

edit flag offensive delete link more

Comments

1

NO. i tried both. i get the error with the Open Studio Plugin only. The Euclid plugin in installed and disabled but was tried AFTER this failed.

TheEnergyTutor gravatar imageTheEnergyTutor ( 2020-08-13 13:01:25 -0500 )edit

My apologies. I saw the "Euclid" in the extensions manager in the background.

Ski90Moo gravatar imageSki90Moo ( 2020-08-14 22:52:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2020-08-13 10:13:42 -0500

Seen: 430 times

Last updated: Aug 13