Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
0

Interior Lighting Summary - Open Studio

asked 2020-07-17 13:22:32 -0500

TheEnergyTutor gravatar image

updated 2020-07-31 08:28:25 -0500

Everything is going fine except i get this error message on the Open Studio Results. Does anyone know what this means and how to fix it?

Interior Lighting Summary
Interior Lighting Summary section failed and was skipped because: Optional not initialized. Detail on error follows.
["
C:/Users/Steve/AppData/Local/Temp/osmodel-1595007927-0/resources/measures/OpenStudioResults/measure.rb:278:in `eval'
C:/Users/Steve/AppData/Local/Temp/osmodel-1595007927-0/resources/measures/OpenStudioResults/resources/os_lib_reporting.rb:3272:in `block in interior_lighting_section'
C:/Users/Steve/AppData/Local/Temp/osmodel-1595007927-0/resources/measures/OpenStudioResults/resources/os_lib_reporting.rb:3271:in `each'
C:/Users/Steve/AppData/Local/Temp/osmodel-1595007927-0/resources/measures/OpenStudioResults/resources/os_lib_reporting.rb:3271:in `interior_lighting_section'
(eval):1:in `block in run'
C:/Users/Steve/AppData/Local/Temp/osmodel-1595007927-0/resources/measures/OpenStudioResults/measure.rb:278:in `eval'
C:/Users/Steve/AppData/Local/Temp/osmodel-1595007927-0/resources/measures/OpenStudioResults/measure.rb:278:in `block in run'
C:/Users/Steve/AppData/Local/Temp/osmodel-1595007927-0/resources/measures/OpenStudioResults/measure.rb:274:in `each'
C:/Users/Steve/AppData/Local/Temp/osmodel-1595007927-0/resources/measures/OpenStudioResults/measure.rb:274:in `run'
:/ruby/2.5.0/gems/openstudio-workflow-2.0.0/lib/openstudio/workflow/util/measure.rb:514:in `apply_measure'
:/ruby/2.5.0/gems/openstudio-workflow-2.0.0/lib/openstudio/workflow/util/measure.rb:109:in `block in apply_measures'
:/ruby/2.5.0/gems/openstudio-workflow-2.0.0/lib/openstudio/workflow/util/measure.rb:67:in `each_index'
:/ruby/2.5.0/gems/openstudio-workflow-2.0.0/lib/openstudio/workflow/util/measure.rb:67:in `apply_measures'
:/ruby/2.5.0/gems/openstudio-workflow-2.0.0/lib/openstudio/workflow/jobs/run_reporting_measures.rb:105:in `perform'
:/ruby/2.5.0/gems/openstudio-workflow-2.0.0/lib/openstudio/workflow/run.rb:292:in `step'
:/ruby/2.5.0/gems/openstudio-workflow-2.0.0/lib/openstudio/workflow/run.rb:234:in `run'
:/openstudio_cli.rb:973:in `execute'
:/openstudio_cli.rb:763:in `execute'
:/openstudio_cli.rb:1757:in `'
eval:149:in `eval'
eval:149:in `require_embedded_absolute'
eval:123:in `block in require'
eval:117:in `each'
eval:117:in `require'
eval:3:in `'
"]
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-07-17 14:48:18 -0500

updated 2020-07-17 14:49:52 -0500

Check if you have any spaces in your model that are not assigned to a thermal zone. That should issue a warning in the reporting measure (logged in out.osw file) for a check of EnergyPlus vs. OpenStudio floor area, and would also cause this section of the report to fail.

edit flag offensive delete link more

Comments

Yeah I have two unconditioned spaces

TheEnergyTutor gravatar imageTheEnergyTutor ( 2020-07-17 14:57:17 -0500 )edit

@TheEnergyTutor, unconditioned is fine, but if you have spaces in the model that are not assigned to a zone, it can be problematic. Can you confirm if there are any spaces that are not assigned to a thermal zone.

David Goldwasser gravatar imageDavid Goldwasser ( 2020-07-17 15:17:47 -0500 )edit

Yeah I never assigned them a thermal zone because they have no heat. I can add it to a new zone.

TheEnergyTutor gravatar imageTheEnergyTutor ( 2020-07-17 15:20:20 -0500 )edit

Yes, it doesn't exist in EnergyPlus if it isn't part of a thermal zone, and that is why the error is coming up because it can't find SQL data for the lights from the space. An unconditioned space is still part of a thermal zone but just doesn't have equipment serving it and generally doesn't have a thermostat. It is important to model it as a zone so you can see what temperatures to expect in the unconditioned space, and because of the impact on adjacent spaces.

David Goldwasser gravatar imageDavid Goldwasser ( 2020-07-17 15:48:21 -0500 )edit

Yes adding a thermal zone to my unconditioned spaces resolved this issue. Thanks.

TheEnergyTutor gravatar imageTheEnergyTutor ( 2020-07-20 09:34:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2020-07-17 13:22:32 -0500

Seen: 54 times

Last updated: Jul 17