OS Error - "Vertex Size Mismatch", followed by "Field level data is of an incorrect type"

asked 2020-07-10 09:32:11 -0600

mdewy gravatar image

updated 2020-09-08 10:09:24 -0600

Hi,

I am trying to run a 2.80 OS model developed in sketchup 2017.

I receive the following error initially:

" * Severe * RoofCeiling:Detailed="SURFACE 1986", Vertex size mismatch between base surface :SURFACE 1986 and outside boundary surface: SURFACE 1944 * ~~~ * The vertex sizes are 8 for base surface and 4 for outside boundary surface. Please check inputs."

When I edit the osm file (with N++) and remove the last 4 of the 8 extra vertices on surface 1986, I try to reopen the OSM file and get this error:

"Model with Version 2.8.0 IDD is not valid to draft strictness level. The collection is INVALID at strictness level 'Draft', because of the errors: Field level data error of type DataType . Error is in an object of type 'OS:Surface', named 'Surface 1986', in field 23. Additional information about the error type: field-level data is of an incorrect type."

I am lost. Please advise on best next steps.

Thanks

edit retag flag offensive close merge delete

Comments

1

You can read more about fixing this issue in this post, which focused on using OpenStudio to split non-convex surface shapes ("L"- or "T"-shaped, e.g.) into smaller convex shapes before surface intersecting and matching. Does that answer your question?

Aaron Boranian gravatar image Aaron Boranian  ( 2020-09-08 10:08:10 -0600 )edit