Problem with modeling fancoil in OpenStudio

asked 2020-04-12 08:27:53 -0500

Yingying Tai gravatar image

updated 2020-04-12 16:53:41 -0500

Hi, I have met the error message when I modeled the FanCoilDoas system in the latest OpenStudio V2.9.1. The error message is as follow:

Program Version,EnergyPlus, Version 9.2.0-921312fa1d, YMD=2020.04.12 10:59,
   ** Severe  ** <root>[Fan:OnOff][Fan Coil with Cycling Fan - Fan 1] - Missing required property 'air_inlet_node_name'.
   ** Severe  ** <root>[Fan:OnOff][Fan Coil with Cycling Fan - Fan 1] - Missing required property 'air_outlet_node_name'.
   **  Fatal  ** Errors occurred on processing input file. Preceding condition(s) cause termination.

I've checked the input in OpenStudio App and the imported idf, there is no object named "Fan Coil Cycling Fan - Fan 1". I have searched on Unmethours for similar questions. It is said that it is because "···they aren't connected to any air-side systems···"(the referenced question is here). I tried to add a new air loop which containing the fan of ZoneHVAC:FourPipeFanCoil. However, it seemed that the component is not allowed to drag to the location. I also tried to use the Measure "AedgOfficeFanCoilDoas" from BCL to "replaces existing HVAC system (if any) with a Fan Coil with DOAS HVAC system". The Measure ran successfully whereas the following running in EnergyPlus went wrong(as it is shown in OS App when click Run). It still got the same error.

I put my osm file here. Does anyone know where the problem is and how to solve it? I would be really appreciated for your help.

edit retag flag offensive close merge delete