Error Running EP FMU export on Simulink

asked 2020-02-27 15:19:16 -0600

Aly ElHefny gravatar image

updated 2020-03-10 15:35:18 -0600

I was trying to run an EPFMU export on simulink, when using an EnergyPlus FMU export on simulink, where my idf file has a running period of 31 days with 1 timestep per hour, the run is stopped by the following error:

Log from FMU: [category:error, status:fmiError] fmiInitializeSlave: A valid time step could not be determined. Log from FMU: [category:error, status:fmiError] fmiInitializeSlave: Can't read time step file.

My stop time of simulink is multiples of 86400. Can someone help please ? Thanks in advance.

**Update: I've tried different versions of Visual Studio including 2013, also I've tried using the Energy+idd of versions 8.6, 8.9 and 9.x. I tried to uninstall all EP versions and keep only one. I've tried replacing the RunPeriod object in the IDF order in the idf text editor as per the discussion of issue #30 (https://github.com/lbl-srg/EnergyPlus...) but still had no luck.

The fmu file generates fine but the simulation stops at the same stage krzysztofarendt experienced in issue#30 with the exact error message related to timestep.

**Update2: I've set the run period in the idf file for 1 day and identified a fixed timestep for the simulink. Now the simulation runs for ever and doesn't allow to pause or stop. No results. I wanted to try the fmu on pyfmi, but when installing the library through python setup.py install --fmil-home=C:\Python27\Lib and python setup.py install --fmil-home=C:\Python27\Lib\FMI_Library , get error option --fmil-home not recognized.

edit retag flag offensive close merge delete

Comments

Could you use a different Master Algorithm to drive your FMU (e.g. PyFMI)?

Thierry Nouidui gravatar image Thierry Nouidui  ( 2020-03-02 23:47:02 -0600 )edit

I'm finding a problem in installing the FMI Library, I've installed the other requirements using pip. Tried for the pyfmi library, python setup.py install --fmil-home=C:\Python27\Lib and python setup.py install --fmil-home=C:\Python27\Lib\FMI_Library , but I get error option --fmil-home not recognized

Aly ElHefny gravatar image Aly ElHefny  ( 2020-03-10 15:15:08 -0600 )edit

Why aren't you installing the pre-compiled binaries as supposed to trying to build it?

Thierry Nouidui gravatar image Thierry Nouidui  ( 2020-03-12 11:53:26 -0600 )edit

Hello Dr. Thierry, can I have your email please?

Aly ElHefny gravatar image Aly ElHefny  ( 2020-03-12 11:58:53 -0600 )edit

nouidui . consulting @ gmail . com

Thierry Nouidui gravatar image Thierry Nouidui  ( 2020-03-13 00:54:48 -0600 )edit