Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

PAT not connecting to AWS

asked 2020-02-06 23:13:54 -0500

BilalMaarouf gravatar image

updated 2020-03-14 11:26:31 -0500

Greetings,

I'm getting an error "Error starting AWS server" when attempting to connect to AWS. I tried different AWS keys, AMI versions, instance types, firewall settings, different computers and two different internet connections.

Would any be able to point out a solution?

  1. Windows 10 Pro build 17134.1246
  2. Openstudio version 2.9.1 (I guess PAT is the same version)?
  3. I attached the debug message: it seems from the yellow highlight that I'm requesting an AWS vCPU higher than my limit?
  4. The AWS EC2 consol screenshot shows my current limits. Should I request a limit increase for [Running On-Demand Standard (A, C, D, H, I, M, R, T, Z) instances]?
  5. I checked my EC2 console and there were no instances launched when running from PAT.

image description image description

Thank you.

edit retag flag offensive close merge delete

Comments

Can you provide more details on what your operating system is and what version of PAT. Also within PAT, if you go to the "View" Menu and choose "Toggle Debug Messages" and also "View/Toggle Developer Tools" you should get a lot more logging of what is happening that you can copy text from or copy an image to add to your post. It would also be useful to know if an EC2 instance is ever launched even if OpenStudio server isn't started on it.

David Goldwasser gravatar imageDavid Goldwasser ( 2020-02-07 11:41:12 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2020-02-16 03:16:34 -0500

BilalMaarouf gravatar image

updated 2020-02-16 03:31:35 -0500

In addition to some of the recommendations below, the solution to this is by:

  1. Before anything, ensure that your AWS account has allowable vCPUs > 36 cores to take full potential of PAT's available AMIs. You can easily request an increase from AWS and you'll get a response within 2 hours.
  2. Setting up a completely new PAT project (don't copy PAT folders or save-as)
  3. Entering AWS cluster settings.
  4. Attempting to connect to AWS. You will notice that this attempt will fail, it's okay.
  5. Save PAT (never force close), close after saving, and then reopen your PAT project
  6. Attempt a connection again to AWS; this will highly likely to succeed.
edit flag offensive delete link more
1

answered 2020-02-07 14:20:48 -0500

@BilalMaarouf please take the content from your answer and post as an update to your question. Then you can delete the answer. It appears though from your log that you may be exceeding the number of machine EC2 servers that you are approved for. the default max number of Amazon EC2 instances is. You may want to first get it working with a small number. Just out of interest, how big of a run are you trying to setup?

edit flag offensive delete link more

Comments

@David Goldwasser my PAT run has about 750 data points (or runs). From the other image I attached, it does seem my vCPU is limited to 5 wherease PAT dropdown menu for AWS have minimum of 8 and up to 36. The number of instances I'm launching is just 1 also per the screenshot.

BilalMaarouf gravatar imageBilalMaarouf ( 2020-02-07 14:36:20 -0500 )edit

The Server Instance Type pull down does result in 8 to 36 vCPU's on the server instance, but that is still just one EC2 instance (of the default minimum of 20). Number of Workers which can be as small as 0 determines how many instances you launch as dedicated workers, in addition to the server, which uses extra cores to run simulations.

David Goldwasser gravatar imageDavid Goldwasser ( 2020-02-07 16:19:38 -0500 )edit

This is understood, requesting a limit increase from Amazon should solve the problem?

BilalMaarouf gravatar imageBilalMaarouf ( 2020-02-07 18:49:01 -0500 )edit

@BilalMaarouf I would recommend lowering the number of workers for now. with 20 38 core instances you can already run 719 simulations at once. You can could go 10x smaller and just run 10 cycles of simulations. Then when you have a need for very large analysis with quick turn around you can use much larger cluster.

David Goldwasser gravatar imageDavid Goldwasser ( 2020-02-07 20:57:10 -0500 )edit

Amazon just increased my limit from 5 to 36 vCPU. I selected the m3.2xlarge Server Instance Type and m3.medium for Worker Instance Type and 0 Number of Workers. This successfully connects with AWS. But I'm confused as to what's the difference between Server and Worker Instance Types? As well, what does 0 Number of Workers really mean?

BilalMaarouf gravatar imageBilalMaarouf ( 2020-02-07 21:58:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2020-02-06 23:13:54 -0500

Seen: 38 times

Last updated: Feb 16