fan coil unit control with setpoint deadband

asked 2020-01-02 20:36:40 -0500

Yingying Tai gravatar image

updated 2020-01-04 10:28:37 -0500

I am modeling a typical FCU system with chilled water plant using one of the DOE commercial reference buildings at EnergyPlus v9.0.1. As far as I know, if the zone temperature is within the deadband([Tset-1/2deadband, Tset+1/2deadband]), the fan coil unit would be turned off temporarily. The valve of the FCU would not be opened until the zone temperature is beyond the Tset+1/2*deadband(If I do not take it wrong......). It is such a common control strategy, right? The zone temperature setpoint I set was 24 Celsius at the occupancy hours with ThermostatSetpoint:SingleCooling. I thought the zone air temperature would fluctuate between 23.5 degree and 24.5 degree with 1 degree deadband. But there seems to be some problems in my simulation.
I have tried to set theTemperature Difference Between Cutout and Setpoint as 0.5 degree in the classZoneControl:Thermostat(For more details, please refer to I/O Reference).

2 - Single Cooling SetPoint
If ( MAT > ThermostatSetpoint:SingleCooling )
ThermostatSetpoint:SingleCooling = ThermostatSetpoint:SingleCooling - DeltaT
Else
No change
End If

But the Zone Air Temperature in my simulation results showed that the lower limit of the zone air temperature was 23.5 degree but it never reached 24 or 24.5 degree as I thought it should have been.
Then I tried to add a new object in ZoneControl:Thermostat:StagedDualSetpoint. As I/O Reference said:

"...When the zone temperature at the previous time step is above the cooling temperature setpoint, the zone cooling setpoint will be set to the cooling temperature setpoint - 0.5 * cooling throttling temperature range. Otherwise, the zone cooling setpoint will be set to the cooling temperature setpoint + 0.5 * cooling throttling temperature range...."

I set the Cooling Throttling Temperature Range as 1 deltaC and Stage 1 Cooling Temperature Offset as 0.5 deltaC. There are two main questions. First, the ZoneControl:Thermostat:StagedDualSetpoint seems not applicable to FCU systems. There was a warning like this:

* Warning * ZoneControl:Thermostat:StagedDualSetpoint is applicable to only selected HVAC objects which are missing from input. Model should include one or more of the following objects:
* ~~~ * AirLoopHVAC:UnitaryHeatPump:AirToAir:MultiSpeed, AirLoopHVAC:UnitarySystem, * ~~~ * SetpointManager:SingleZone:OneStageCooling, and/or SetpointManager:SingleZone:OneStageHeating.

But it seemed not interfere the simulation and the simulation continued. I ignored the warning and inspected the results. This time the zone air temperature fluctuated with the lower limit of 24.5 degree but still did not reached 24 degree either.
How can I set the deadband for the control of FCU? Do I need to use EMS to set this control strategy for each thermostat? Do you have any ideas? I would be really appreciated if any of you could give me some advice. Thank you very much~

edit retag flag offensive close merge delete

Comments

@Yingying Tai were you able to resolve this issue? If not, could you include a link to your IDF or add the object text to your post?

Aaron Boranian gravatar imageAaron Boranian ( 2020-07-28 08:32:59 -0500 )edit