Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
2

How to simulate for 365 days, currently it is only doing simulation for 18 days (at intervals of 20 days)?

asked 2019-12-17 03:07:57 -0500

Arceus gravatar image

updated 2020-01-07 16:58:35 -0500

Here is the Runperiod Data present in my IDF File, Energyplus v9.1.0

RunPeriod,
  WholeYearDay,            !- Name
  1,                       !- Begin Month
  1,                       !- Begin Day of Month
  ,                        !- Begin Year
  12,                      !- End Month
  31,                      !- End Day of Month
  ,                        !- End Year
  Tuesday,                 !- Day of Week for Start Day
  Yes,                     !- Use Weather File Holidays and Special Days
  Yes,                     !- Use Weather File Daylight Saving Period
  No,                      !- Apply Weekend Holiday Rule
  Yes,                     !- Use Weather File Rain Indicators
  Yes,                     !- Use Weather File Snow Indicators
  ;                        !- Treat Weather as Actual

Edit: Simulation Control Object settings.

SimulationControl,
    Yes,                     !- Do Zone Sizing Calculation
    Yes,                     !- Do System Sizing Calculation
    Yes,                     !- Do Plant Sizing Calculation
    No,                      !- Run Simulation for Sizing Periods
    Yes;                     !- Run Simulation for Weather File Run Periods
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2019-12-24 08:24:12 -0500

updated 2019-12-24 19:10:00 -0500

It sounds like you are indeed running an annual simulation (365 days) but are confused by the fact that EnergyPlus displays the progress of its simulation in 20 day increments (by default). This is because the ShadowCalculation's Calculation Frequency has a default value of 20 days.

Note the progress output refers to the shadow calculations:

Updating Shadowing Calculations, Start Date=05/21/2007
Continuing Simulation at 05/21/2007 for RUN PERIOD 1
Updating Shadowing Calculations, Start Date=06/10/2007
Continuing Simulation at 06/10/2007 for RUN PERIOD 1

If you changed this input to 1 day, you would get 365 output progress messages that are 1 day apart during the simulation -- however this will increase runtime (and affect simulation results).

I've never understood why EnergyPlus's runtime output progress is linked to this shadow calculation frequency. It seems like it could easily offer an input that governs the output progress that is independent of the shadow calculation frequency. But anyway, that's how it is.

edit flag offensive delete link more
1

answered 2019-12-17 03:23:25 -0500

Make sure the SimulationControl object has the field Run Simulation for Weather File Run Periods enabled, eg:

SimulationControl,
  Yes,                      !- Do Zone Sizing Calculation
  Yes,                      !- Do System Sizing Calculation
  Yes,                      !- Do Plant Sizing Calculation
  No,                       !- Run Simulation for Sizing Periods
  Yes;                      !- Run Simulation for Weather File Run Periods
edit flag offensive delete link more

Comments

Please check the edit, what you suggested was already present, but still i am not able to run the simulation for 365 days.

Arceus gravatar image Arceus  ( 2019-12-23 23:26:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2019-12-17 03:07:57 -0500

Seen: 158 times

Last updated: Dec 24 '19