Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
0

OpenStudio cannot open file

asked 2019-12-10 14:35:14 -0500

Hello, I am having trouble opening a file - I'm in v2.7.0 and whenever I try to open the osm, the program simply crashes. I can send over the file if someone is able to take a look.

Thanks!

edit retag flag offensive close merge delete

Comments

What version of the OpenStudio App are you using? And what version is the file you are trying to open? (You can open it in a text editor and see).

mdahlhausen gravatar imagemdahlhausen ( 2019-12-11 09:22:32 -0500 )edit

I was using v2.7.0 (both the app and the file), but upgraded to v2.9.1 to see if that would fix anything. So now both the file and the app are v2.9.1. I still get the same problem with the program crashing, but figured out that it is related to adding the OpenStudio Results reporting measure. Whenever I try to run it with that, the program crashes and subsequently I am not even able to open the file.

Phan Truong gravatar imagePhan Truong ( 2019-12-11 12:05:58 -0500 )edit

Open your model in the app before applying any measures. Click through all the tabs. Does your model crash on any of the tabs? Have you edited your model in either a text editor or other software? My guess is you deleted some critical zone or space information in another software before opening it in the app.

mdahlhausen gravatar imagemdahlhausen ( 2019-12-11 14:44:42 -0500 )edit

Hmm, the file runs just fine without the OpenStudio Results measure though. What could be the reason for that?

Phan Truong gravatar imagePhan Truong ( 2019-12-11 14:48:37 -0500 )edit

Are you using the most recent version of the OpenStudio Results measure from BCL? I'd suggest deleting it from your local BCL directory and my measure directory, if present, and then re-downloading the measure. If you still get an error, post a link to your model here.

mdahlhausen gravatar imagemdahlhausen ( 2019-12-13 10:47:00 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-12-16 11:39:19 -0500

@Phan Truong what operating system are you using? I was able to open the model and OpenStudio Results and run the simulation, save, quit, and re-open the model. I do see a crash when I go to the geometry tab to view 3d geometry, however it opens fine in the SketchUp Plugin. I'll look into the cause of this.

For reference, in inspecting the model in the SketchUp Plugin I noticed a few surfaces that should have been roofs that were floors instead. I believe they may have been roofs with reversed face normals that the plugin altered. Either way that should be addressed in your model. I also noticed you were using adiabatic boundary conditions for interior walls. It looks like you intended to do this for floor/ceilings as well, but while ceilings were made adiabatic, the floors of all spaces still have a ground boundary condition, which you should change.

image description

For reference, here is view of the Results HTML.

image description

I'll update this answer once I identify the cause of the crash on viewing of geometry in OS app.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2019-12-10 14:35:14 -0500

Seen: 164 times

Last updated: Dec 16 '19