Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question

Why does the availability managers night cycle can't show the zone

asked 2019-09-27 15:27:47 -0600

Westely's avatar

updated 2019-09-29 10:11:30 -0600

Hello all: I set an AM night cycle in my model, and seems I can select the control zone under the option "cycleoncontrol zone". but the menu does not show the zone name, just some numbers. I was wondering if it is a bug, or I set something incorrectly? Thanks.image description

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2019-10-04 03:18:00 -0600

These fields shouldn't be displayed in the OpenStudioApplication to begin with. I added an issue on Github NREL/OpenStudio#3707

If you want to set this, you have to use the API directly (via the ruby bindings or an OpenStudio Measure).

Here's a demonstration of the API for these fields:

require 'openstudio'
include OpenStudio::Model
m =
a =
z =
atu =, m.alwaysOnDiscreteSchedule)
a.addBranchForZone(z, atu)

# 1. This will create an AvailabilityManagerNightCycle
# a.setNightCycleControlType("CycleOnAny")
# avm = a.availabilityManagers[0]
# avm_nc = avm.to_AvailabilityManagerNightCycle.get

# 2. Alternatively you can directly create one and add it to the AirLoopHVAC
avm_nc =

# Check all Control Type that you can set
#=> ["StayOff",
# "CycleOnAny",
# "CycleOnControlZone",
# "CycleOnAnyZoneFansOnly",
# "CycleOnAnyCoolingOrHeatingZone",
# "CycleOnAnyCoolingZone",
# "CycleOnAnyHeatingZone",
# "CycleOnAnyHeatingZoneFansOnly"]

# Depending on the control type you choose, you'll have to use one or several of these methods to set the correct zones
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops


Question Tools

1 follower


Asked: 2019-09-27 15:27:47 -0600

Seen: 130 times

Last updated: Oct 04 '19