Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
3

How to input Glycol Concentration in Open Studio?

asked 2019-08-06 14:48:47 -0500

nsimhai gravatar image

updated 2019-08-07 10:31:14 -0500

I'm having trouble getting the input for Glycol Concentration in OS:PlantLoop to work. The Input-Output Reference for FluidProperties:GlycolConcentration indicates that the value should be a number between 0 and 1.

However, when trying to enter the input in the plant loop in OS v2.7, regardless of what fluid type is selected, it does not allow values with a decimal point to be entered.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
6

answered 2019-08-07 10:15:27 -0500

In OpenStudio, the Glycol Conentration in the PlantLoop object is wrapped by the glycolConcentration parameter, which you can see from the SDK, is a int value. I went into the source code on GitHub and found that the Forward translator multiplies this number to get is as a percentage. I wonder what was the decision behind this implementation.

Therefore, you have to input 50% glycol concentration as 50. When the model get's translated, it will be multiplied 50*0.01 and be passed to the IDF as 0.5.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 



Question Tools

1 follower

Stats

Asked: 2019-08-06 14:48:47 -0500

Seen: 166 times

Last updated: Aug 07