I'm using GenOpt coupling with EnergyPlus to minimize the LCC but this variable that I need to minimize doesn't appear in the .eso file of E+

asked 2019-06-07 12:35:13 -0600

melanie gravatar image

updated 2019-06-07 13:09:03 -0600

I'm using GenOpt coupling with EnergyPlus to minimize the LCC. In the .eso file resulting from the simulation in E+ doesn't appear any variable related to the calculation of the LCC. In the initialization file (.ini) of GenOpt I need to reference the delimiter of the .eso file corresponding to the variable that I want to minimize (LCC). BUT as in the .eso file of E+ the variable that I need to minimize doesn't exist, what can I do??

edit retag flag offensive close merge delete

Comments

Get it from the Output:Table:SummaryReports in the HTML or the SQL file (if requested). You'll have to write for eg a python script to do that, but it should be quite straightforward.

Julien Marrec gravatar image Julien Marrec  ( 2019-06-09 17:52:24 -0600 )edit