Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
1

JE Plus not working with Energy Plus v9.0+?

asked 2019-05-23 20:29:17 -0500

Abarker gravatar image

I was wondering if there were any known issues regarding using JEplus and Energy Plus version 9.0.

I am running into an issue where my JE Plus project is validated and runs well, however is not compiling any results. I have narrowed the issue down to my version 9.0 projects only, as it has always worked very well for version 8.8. I have just verified this by running JEplus on a version 8.8 project and verifying the results are produced (e.g. SimResults.csv shows complied results).

I then updated the Energy Plus file to version 9,.0, ran it again in JE Plus with all else equal, and am not able to produce complied results (SimResults.csv file is empty). I note that the model does simulate with no issues as all of the individual output files are created in their folders.

Is there another setting specific to version 9.0 that I should be changing to get it to work with JEPlus? I am using version JEPlus v1.7.2.

Below is the .rvi file I am using, which is quite simple (I almost always this rvi file for most projects so am confident it works):

eplusout.mtr eplusout.csv Electricity:Facility Gas:Facility HeatingCoils:EnergyTransfer 0

here are my output meters:

Output:Meter,Electricity:Facility,Annual;

Output:Meter,Gas:Facility,Annual;

Output:Meter,HeatingCoils:EnergyTransfer,Annual;

Any help appreciated.

Adam

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-05-26 10:25:56 -0500

Yi Zhang gravatar image

updated 2019-05-26 10:26:46 -0500

Hi Adam,

Thanks for raising this question! From E+ v8.9, the output frequency "Annual" and "RunPeriod" have been given different meanings. They were the same in the versions prior to that.

In jEPlus, the default output frequency is "RunPeriod" when RVI is used, hence it has troubles collecting "Annual" results from v8.9 and 9.0 models. You can either change to output frequency in the IDF to "RunPeriod", e.g.

Output:Meter,Electricity:Facility,RunPeriod;

Or to create a RVX file and specify "Annual" in the RVI object, such as:

my.rvx

{
    "rvis" : [ 
        { 
            "fileName" : "my.rvi",
            "tableName" : "Consumptions",
            "frequency" : "Annual",
            "usedInCalc" : true
        }
      ]
}

More details about the RVX can be found here: http://www.jeplus.org/wiki/doku.php?i...

Yi

edit flag offensive delete link more

Comments

Thanks very much Yi, this worked! Simple solutions are the best solutions.

Abarker gravatar image Abarker  ( 2019-05-27 08:27:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2019-05-23 20:29:17 -0500

Seen: 143 times

Last updated: May 26 '19