Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
2

Warning: Latitude of 20 was assumed for Manual J solar load calculations

asked 2019-03-21 11:03:47 -0500

patrick1751 gravatar image

updated 2019-03-22 10:47:33 -0500

I am a new user who is trying to get the temperatures and relative humidity of a designed container house (located in Tacloban, Leyte, Philippines) in BEOpt. While running my designs, I kept getting the following warning:

3/21/2019 11:48 PM: 1.xml: Warning: Latitude of 20 was assumed for Manual J solar load calculations. 3/21/2019 11:48 PM: 2.xml: Warning: Latitude of 20 was assumed for Manual J solar load calculations. 3/21/2019 11:49 PM: 3.xml: Warning: Latitude of 20 was assumed for Manual J solar load calculations. 3/21/2019 11:54 PM: 4.xml: Warning: Latitude of 20 was assumed for Manual J solar load calculations.

Does this warning affect the results of my designs? Is there any way of fixing this warning?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2019-04-03 15:42:38 -0500

Esolver gravatar image

The table is coded within a file called:

your_install_directory\BEopt_2.8.0\Modeling\sizing.py

This file is fun to edit in circumstances such as yours.

If you want to disable the warning, simply replace line 408 with "pass". The latitude is pulled from your weather file on line 402:

if cnt == 0:
    # SimWarning('Latitude of 20 was assumed for Manual J solar load calculations.')
    pass

Also, you could take an attempt at adding your latitude's values to the table...down on line 233 there a table with peak solar heat gain values that correspond to latitudes, but I"m not going to figure out how to do that for you and the solution mentioned by Jon W seems to be the reasonable one:

# Peak solar factor (PSF) (aka solar heat gain factor) taken from ASHRAE HOF 1989 Ch.26 Table 34
# (subset of data in MJ8 Table 3D-2)            
# Surface Azimuth = 0 (South), 22.5, 45.0, ... ,337.5,360 and Latitude = 20,24,28, ... ,60,64
mj8.psf =      [[ 57, 72, 91, 111, 131, 149, 165, 180, 193, 203, 211, 217],
                [ 88, 103, 120, 136, 151, 165, 177, 188, 197, 206, 213, 217],...and so on]

That list can be edited to include lower latitudes and will affect ouput in BEopt, but that could be a giant rabbit hole and may (probably) cause other things to break and therefore would need to be debugged appropriately. You may need to edit some other portions of that file to get it all to work and it might not be worth your time. note: I would recommend making a copy of that file so if you screw it up you can revert back easily.

edit flag offensive delete link more
1

answered 2019-03-22 15:01:05 -0500

Jon W gravatar image

Hi. This warning is due to the BEopt air conditioner autosizing routines that use ACCA Manual J. The solar data tables included in Manual only go down to a latitude of 20°.

I don't think there is a way to disable this warning. To ensure you have a properly sized air conditioner, I would recommend reviewing the hourly output and comparing the indoor temperature to the set point. If the autosizing routine is providing an unsatisfactory result, I would recommend fixing the size of the air conditioner using the dropdown menu on the Options screen in the Air Conditioner category.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2019-03-21 11:03:47 -0500

Seen: 190 times

Last updated: Mar 22 '19