Energy+ and FMU initial conditions problem

asked 2019-03-15 07:09:09 -0500

Paolo gravatar image

updated 2019-03-17 11:11:45 -0500

Deal all, I wrapped an EnergyPlus model using the EnergyPlusToFMU tool. Since we will run experiment in real time and with setpoints/meteo/renewableEnergy that comes from the outside (optimization, weather station, PVstation), I configured the idf in order to accept all this external signals. Everything seems to work correctly, a part for one thing. Rooms temperature (and %humidity) at the beginning of the simulation are really low (see picture 1 where the first day is represented, 180s simulation timestep). The strange thing is that if I remove the actuator that overwrites the outdoor air bulb temperature, temperatures initialize well!

ps: I launched the two FMU with a simulator. The only difference between the two FMUs is the above-mentioned actuator (that I must use!) Could be this a bug? Thank in advance for the answer. Paolo

C:\fakepath\ZoneTemperature_noDRYBULB.PNG

C:\fakepath\ZoneTemperature.PNG

edit retag flag offensive close merge delete

Comments

Have you set the initial conditions of the ExternalInterface actuators you are using?Those are the values which will be used during warm-up period of your model.

Thierry Nouidui gravatar imageThierry Nouidui ( 2019-03-15 14:18:34 -0500 )edit

Hi Thierry, yes, I set the initial conditions and I found two issues: 1) for any initial conditions I set (weather variables or heating set point) the room temperature initialization does not change. 2) if I try to left the field in blank, simulation gives a fatal error at the beginning.

Best, Paolo

Paolo gravatar imagePaolo ( 2019-03-18 03:44:27 -0500 )edit