Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question

BEopt Optimization Running Super Slowly

asked 2019-02-28 11:51:11 -0500

Alisa's avatar

updated 2019-03-02 12:52:24 -0500


I am running a BEopt model on a remote server that I built for it to run quickly. The remote server has 8 VCPUS and 32 GB of memory and the CPU is running at 100%, yet the model hasn't even completed one iteration in 24 hours. Is there something I'm missing to make this run faster? At this speed, it would take over a month for the optimization to complete. Normally my multifamily models take a while, but not more than 10 days and with this high powered machine I would have anticipated it would be done after 4 days or less. I attached the model in question.

Thank You! Alisa

edit retag flag offensive close merge delete


Do you happen to be modeling one stratified water heater per unit?

mdahlhausen's avatar mdahlhausen  ( 2019-02-28 12:37:40 -0500 )edit

Yes it is using the heat pump water heater option which includes a stratified tank. Unfortunately since tank stratification isn't something we can change within BEopt I'm not sure how to resolve this.

Alisa's avatar Alisa  ( 2019-02-28 12:57:19 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2019-02-28 13:05:06 -0500

We are actively working on improving HPWH stratified tank runtime.

In the meantime, I would recommend running the optimization with an electric resistance water heater and then running a parametric to add in a HPWH to the point(s) of interest.

edit flag offensive delete link more


You can follow the progress of this work at We expect this improvement to make it into EnergyPlus 9.1.0.

shorowit's avatar shorowit  ( 2019-02-28 20:02:58 -0500 )edit

Thanks. I updated the model with this in mind, but am still having the same issue. My model has been running for 21 hours and is still on iteration 1 run 8. Is there something else that could be making it especially slow?

Alisa's avatar Alisa  ( 2019-03-01 10:21:50 -0500 )edit

@Alisa, multifamily models with many units, smaller than normal timesteps (e.g., to support PCM analysis), and optimizations with many options selected could all be causing longer optimization times.

Eric Wilson's avatar Eric Wilson  ( 2019-03-01 10:32:58 -0500 )edit

I am already using 60 min timesteps to avoid this and it has been stuck on iteration 1 run 8 for 20 hours without making any progress (it did iteration 1 run 1-7 in the first hour). Is there any chance it's doing a calculation for this long? Seems unlikely, but I don't want to stop the run if that is the case and lose the 21 hours of work.

Alisa's avatar Alisa  ( 2019-03-01 10:38:13 -0500 )edit

Will we ever get to see the benefits of these improvements? BEopt is currently stuck at EnergyPlus 8.8

jpierce's avatar jpierce  ( 2021-01-26 17:11:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops


Question Tools

1 follower


Asked: 2019-02-28 11:51:11 -0500

Seen: 470 times

Last updated: Feb 28 '19