My model crashes and I lose all geometry

asked 2019-02-07 14:23:33 -0500

mark.stout gravatar image

updated 2019-02-07 14:23:54 -0500

Hi all,

Not sure how else to describe it. I'm using Sketchup 2018 with OpenStudio v2.7.0 enabled and I'm creating a energy model. I have different floor heights, with my mixed use first floor 15' and the rest 12'. So I do the floor layout the first floor. I save it and save a copy. I use "Create Spaces From Diagram". I can't do all 5 floors, so I just do the one for 15'. I'm periodically saving the model in addition to the auto-save. Everything is going going along fine and then suddenly I get an error message, something is wrong work my geometry. Not sure what I did to create the error. So I exit and reload Sketchup. Of course the attached .osm that looks like what I was working on appears, but so does the dialog box telling I have to reload the .osm file. When I do this I either get a wire frame of my model and screw it, nothing works. So I exit and relaunch Sketchup only this time I open the .osm without opening the .skp file. Nothing. No .osm file loads.

Starting over with the copy I made, I find this too is also a wire frame. Not the layout I save with the rectangle I created that was grey and all my outlines for the floor. That point where I would normally click "Create Spaces From Diagram". Again, nothing I do gets me back to where I need to be.

I have rebooted my machine and run nothing else but Sketchup thinking maybe there's a conflicting DLL. And still get the same problem. Is Sketchup and OpenStudio supposed to be this buggy? Or am I not doing something I should be doing? HIs there a better solution than Sketchup and OpenStudio for modeling the energy performance of either existing or new construction?

Getting really frustrated here.

edit retag flag offensive close merge delete

Comments

1

@mark.stout It sounds like you are using the File / Save menu, which will ONLY save the .skp file. You want to save the .osm file for OpenStudio, which you do in the Extensions / OpenStudio / Save menu (or in the OpenStudio toolbar you see in SketchUp). Is this the case?

Aaron Boranian gravatar imageAaron Boranian ( 2019-02-07 14:27:08 -0500 )edit

Nope. I have been saving the both the Sketchup file and the OpenStudio file. Just redo the floor layout to the point where I would use "Create Spaces From Diagram" I saved both files, and I saved a backup of both files. Closed down Sketchup, relaunch Sketchup, loan the Sketchup file, it loads fine. Get the dialog box telling it's going to unload the .osm file. Say OK. The click to open the .osm file and either get a Bug Splat error, or the file loads but it's in wireframe. Same thing happens when I load the backup I created. Relaunching Sketchup the Sketchup person is also wireframe.

mark.stout gravatar imagemark.stout ( 2019-02-07 15:58:57 -0500 )edit

Now when I try to load just the .osm file, I get nothing. My floor layout is not there. Looks like a brand new startup page. When I open it in OpenStudio and click the Geometry tab, I get nothing. It takes about minutes to layout the floor and I've done it like 5 times over the last two days. This is on WIndows 10 if that means anything.

mark.stout gravatar imagemark.stout ( 2019-02-07 16:02:07 -0500 )edit

You only want to be working with the .osm file -- don't bother with the .skp file. So, only save the .osm file and only open the .osm file when working in SketchUp. When you open the .skp file, then click "unload the .osm file", that is likely what's messing you up.

Aaron Boranian gravatar imageAaron Boranian ( 2019-02-07 16:59:34 -0500 )edit

Is that corrupting the .osm file?

mark.stout gravatar imagemark.stout ( 2019-02-07 17:53:33 -0500 )edit