Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
2

Coordinates in Openstudio Geometry are mirrored

asked 2019-01-22 18:40:02 -0500

mldichter gravatar image

I noticed this problem after adding shading surfaces to the model.

The x and y coordinates appear to have flipped sign when viewed in the geometry tab.

image description

This surface should have coordinates with negative x value, negative y value, and positive z value. However, looking in the osm file as text, the x and y values are the wrong sign.

OS:Surface,
  {3779ebcb-020c-4d16-8943-972085eddbf9}, !- Handle
  R_GuestRoom401_1_0_0,                   !- Name
  RoofCeiling,                            !- Surface Type
  {985f3067-a3f1-45c7-a798-fe3fe16ec7dd}, !- Construction Name
  {f5254cf8-5b99-4e81-8046-88b847399396}, !- Space Name
  Outdoors,                               !- Outside Boundary Condition
  ,                                       !- Outside Boundary Condition Object
  SunExposed,                             !- Sun Exposure
  WindExposed,                            !- Wind Exposure
  ,                                       !- View Factor to Ground
  ,                                       !- Number of Vertices
  4.011084424, 0.0488452197, 11.5824,     !- X,Y,Z Vertex 1 {m}
  4.011084424, 8.2790292198, 11.5824,     !- X,Y,Z Vertex 2 {m}
  0.048684424, 8.2790292198, 11.5824,     !- X,Y,Z Vertex 3 {m}
  0.048684424, 0.0488452197, 11.5824;     !- X,Y,Z Vertex 4 {m}

Then it gets weirder as my shading surfaces are positioned correctly with their vertices in the geometry tab.

image description

OS:ShadingSurface,
  {94812bd8-1ad1-4ca0-a666-314b75b4e180}, !- Handle
  Thermal Shading Object 0,               !- Name
  ,                                       !- Construction Name
  {7daae927-2853-40ea-ab18-c022234ce011}, !- Shading Surface Group Name
  ,                                       !- Transmittance Schedule Name
  ,                                       !- Number of Vertices
  3.511084424, 0.5488452197, 11.6824,     !- X,Y,Z Vertex 1 {m}
  3.511084424, 1.2088452197, 11.6824,     !- X,Y,Z Vertex 2 {m}
  0.851084424, 1.2088452197, 11.6824,     !- X,Y,Z Vertex 3 {m}
  0.851084424, 0.5488452197, 11.6824;     !- X,Y,Z Vertex 4 {m}

What's going on? Here is a link to the osm file with this behavior.

image description

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2019-01-23 09:29:25 -0500

The surface coordinates are ok, but appear wrong because the building has been rotated 180 degrees:

OS:Building,
  {a262edd0-e652-492b-9637-0fab3a5064a0}, !- Handle
  SmallHotel,                             !- Name
  ,                                       !- Building Sector Type
  180,                                    !- North Axis {deg}
  ,                                       !- Nominal Floor to Floor Height {m}
  ,                                       !- Space Type Name
  ,                                       !- Default Construction Set Name
  ;                                       !- Default Schedule Set Name

'Site' shading surfaces don't rotate with the building.

edit flag offensive delete link more

Comments

@Eric Ringold Thanks! That was it. I changed all my Shading:Site:Detailed to Shading:Building:Detailed objects and all the rotations were taken care of for me.

mldichter gravatar imagemldichter ( 2019-01-23 10:13:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2019-01-22 18:40:02 -0500

Seen: 41 times

Last updated: Jan 23