Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
1

OpenStudio SketchUp Installation

asked 2015-03-11 19:55:47 -0500

santiag987 gravatar image

updated 2016-01-15 15:29:16 -0500

Hi

I'm having problems with OpenStudio Legacy installation.

operating system : Windows 7 ultimate SP1 -- 32 bit

I performed the installation as follows:

  1. Sketch up 2015 pro 32 bit
  2. Energy plus 8.2 (EnergyPlus-8.2.0-8397c2e30b-Windows-x86_64) * 32 bit and 64 bits in the same installer I assume
  3. Open studio plugin (OpenStudio-1.0.11 414) 32 bit
  4. Open studio legacy (OpenStudio-1.6.0.1229eac298-Windows) 32 bit

All install directory by default in "C"

In 4, during installation a problem occurs. (see pic: https://www.dropbox.com/sh/wk0iocvhv7...)

If my PC architecture is 32 bits i cant install SketchUp 64 bits. I don't know what is wrong I don't understand the message: "32 bit Open studio is incompatible with 64 bit SketchUp 2015 OpenStudio plug-in will not be installed"

Please help.

I tried not installed E+, step 2. (OpenStudio 1.6.0 works with EnergyPlus 8.2.0 Update 1, which is now bundled with the OpenStudio installer. It is no longer necessary to download and install EnergyPlus separately.)

but the same problem occurs.

Thanks

edit retag flag offensive close merge delete

Comments

I am working on a new installer for the legacy plug-in that will work with SketchUp's extension warehouse. Please email me at OpenStudio@nrel.gov and I will send you a link to an rbz file to try out.

macumber gravatar image macumber  ( 2015-03-11 22:19:15 -0500 )edit

Also, did your OpenStudio 1.6.0 installation work correctly?

macumber gravatar image macumber  ( 2015-03-11 22:20:27 -0500 )edit

Like i said, the problem is in the Open Studio 1.6.0 installation step4 (I think the installation of plugin is performed correctly step3)during OpenStudio 1.6.0 installation is reported: the OpenStudio plugin will not install which makes no sense Cos it was previously installed in step3(?) comment: During plugin installation I find it strange that a folder SketchUp2014 is generated automatically when I installed a 2015version, this can cause errors and I find it quite confusing. On the other hand the link http://sourceforge does not work. anyone else would this happen?(I have really bad luck)

santiag987 gravatar image santiag987  ( 2015-03-12 19:29:35 -0500 )edit

I tried to install SketchUp 8 Pro (most used version for me) in C/Program files/Google/SketchUp etc. and during OpenStudio 1.6.0 installation is required SketchUp2015. (Why?) and again is not installed Open Studio Plugin.

santiag987 gravatar image santiag987  ( 2015-03-12 21:14:16 -0500 )edit

it is a pity but for now I'll have to use the last version that worked:

1) SketchUp 8 pro 2)Enegy plus 8 3) Openstudio plugin 1.0.11 4) Openstudio 1.3.0

I hope you can solve this problem. I think the problem is in the installer open studio1.6.0 with 32 bit arq.

santiag987 gravatar image santiag987  ( 2015-03-12 21:26:09 -0500 )edit

1 Answer

Sort by » oldest newest most voted
4

answered 2015-03-12 18:20:05 -0500

updated 2015-03-13 08:53:19 -0500

If the problem is installing the legacy plug-in: we are updating the installer for the Legacy OpenStudio SketchUp Plug-in from executable installers to the SketchUp rbz format, http://help.sketchup.com/en/article/38583. This format will make it much easier to update and distribute the Legacy OpenStudio SketchUp Plug-in. The first version of this installer is available for testing at:

http://sourceforge.net/p/openstudio/code/HEAD/tree/branches/rbz/legacyopenstudiov1.0.11.rbz

This installer is an analog of the 1.0.11 version that is currently available; it works with EnergyPlus 8.1. To install this new plug-in, go to ‘Window->Preferences->Extensions’, choose install extension and browse to the rbz file. Note that installing this rbz file will disable your currently installed Legacy OpenStudio SketchUp Plug-in by moving the ‘Plugins/OpenStudio/Energy+.idd’ to ‘Plugins/OpenStudio/Energy+.idd.removed’. If you want to restore your old Legacy OpenStudio SketchUp Plug-in, simply delete the new ‘legacyopenstudio’ directory and ‘legacyopenstudio.rb’ ruby script in your Plugins directory and rename the ‘Energy+.idd.removed’ to Energy+.idd’ under the ‘OpenStudio’ directory.

If you are able to, please test out this new installer and let us know about any issues. We will plan to replace the installer hosted on the DOE website with this one in the near future.

If your problem is installing the new OpenStudio application suite: can you check if you have the following directory?

C:\ProgramData\SketchUp\SketchUp 2015\SketchUp

If you don't have that directory, please copy the files in:

C:\Program Files (x86)\OpenStudio 1.6.0\Ruby\Plugins

to:

C:\Users\%YOURUSERNAME%\AppData\Roaming\SketchUp\SketchUp 2015\SketchUp\Plugins

where %YOURUSERNAME% is replaced by your user name.

edit flag offensive delete link more

Comments

Macumber, copy and paste the files it worked. Honestly I cant believe it's been easier. really thanks!

santiag987 gravatar image santiag987  ( 2015-03-13 20:31:46 -0500 )edit

Macumber, in a similar case of my Sketchup apparently not being able to find the openstudio package that I installed, I had a C:\ProgramData\SketchUp\SketchUp 2016\SketchUp directory, with a 'plugins' folder in it, but for some reason I still needed to do that copying trick you described above to make Sketchup actually load with the Openstudio plugin. All seems well now...should I assume that the workflow will now function correctly?

gsuscalo gravatar image gsuscalo  ( 2017-03-20 21:14:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

2 followers

Stats

Asked: 2015-03-11 19:55:47 -0500

Seen: 58,256 times

Last updated: Jan 15 '16