Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
2

OpenStudio Spaces in Sketchup - Surface Matching

asked 2018-12-05 19:05:05 -0600

mcdonaa1 gravatar image

updated 2018-12-06 13:03:26 -0600

Open Studio: Having a problem with OpenStudio Spaces drawn in Sketchup.

I am putting together a two-story data center; see attached pictures. Corridor space surrounds various server rooms like a square donut with the servers as the filling on both floors. Note: the top floor also maintains a 3 ft plenum.

When I match surfaces and run the model, OpenStudio automatically fills the corridor "donut" for some reason, overlapping with the server rooms (see the 'exploded' pictures). Is there any way to prevent this from happening?

As a work around, I have split the rectangular donut with seams, and then joined them as one thermal space being run by the same AHU equipment. This seems to yield accurate enough results. Is this the correct approach if OpenStudio cannot handle donut or courtyard-like spaces?

Initial Data Center Assembly image description

Exploded Data Center Corridors BEFORE Surface Matching image description

Exploded Data Center Corridors AFTER Surface Matching image description

Work around = Split Rectangular Donut with Seams, Reassemble with Shared Thermal Zones, Surface Match, and then Run Model image description

edit retag flag offensive close merge delete

Comments

@mcdonaa1 looking at the exploded pre-matched view, one confusing thins isn't so much the do donut shaped zones, it is that the roof, and I assume floor isn't split up. It shouldn't be possible to open up an OSM that looks like this since OSM files, like EnergyPlus don't have concept of inner loops for surfaces. If you drew a skylight, then deleted the skylight surface (but not edges) and then drew walls you might be able to construct something that looks like this, but if you saved, and re-opened it without surface matching, it wouldn't look like you expect.

David Goldwasser gravatar imageDavid Goldwasser ( 2018-12-07 09:53:13 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2018-12-06 10:11:45 -0600

jmbattis gravatar image

It is true that the surface-matching feature struggles with donut-shaped zones. What you're describing (duplicate ceilings being created over these zones) is pretty typical from what I've experienced. You can correct this by manually deleting, intersecting, and matching surfaces, but if your work-around is automatically resulting in the desired surface matching and boundary conditions when you run the intersect and match measures, you've definitely landed on the more efficient solution.

I think, though, that E-Plus in general struggles with donut-shaped zones - not just from a matching perspective, but from radiation and heat-balance calculation perspectives as well. So even if you are able to appropriately set up zones of this shape, it's probably best to avoid them. I go as far as avoiding H- and C-shaped zones, when I can, as well. Not sure if this is just superstition or is actually prudent, but I just do it to avoid having to troubleshoot later. The image below shows how I'd divide the same zones - of course this does result in more zones than is explicitly necessary.

image description

edit flag offensive delete link more

Comments

Thanks - much appreciated!

mcdonaa1 gravatar imagemcdonaa1 ( 2018-12-06 17:28:52 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2018-12-05 19:05:05 -0600

Seen: 80 times

Last updated: Dec 06