Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
2

Reset the infiltration by ems

asked 2018-10-29 21:41:07 -0500

shellyhong gravatar image

updated 2018-10-30 21:37:43 -0500

I encounter difficulty in the EMS code in control the thermal chimney air flow. And I was wondering if anyone can give some suggestion.

The zonethermalchimney object was chosen and the discharged amount of interior air from each zone is assumed to be replaced by the infiltration.

The control logic is, when HVAC set on, the air flow mass because of the solar chimney can no more than the fresh air required in the zone. So, I add a ems program in infiltration, here is my code.

EnergyManagementSystem:Sensor,
  INFIL1,                  !- Name
  1F,                      !- Output:Variable or Output:Meter Index Key Name
  Zone Infiltration Air Change Rate;  !- Output:Variable or Output:Meter Name

EnergyManagementSystem:Sensor,
  INFIL2,                  !- Name
  2F,                      !- Output:Variable or Output:Meter Index Key Name
  Zone Infiltration Air Change Rate;  !- Output:Variable or Output:Meter Name

EnergyManagementSystem:Sensor,
  VRFMODE,                 !- Name
  VRF SYS 1 AIR SOURCE VRF HEAT PUMP,  !- Output:Variable or Output:Meter Index Key Name
  VRF Heat Pump Operating Mode;  !- Output:Variable or Output:Meter Name

EnergyManagementSystem:Sensor,

INFIL1M3,                !- Name
1F,                      !- Output:Variable or Output:Meter Index Key Name
Zone Infiltration Current Density Volume Flow Rate;  !- Output:Variable or Output:Meter Name

EnergyManagementSystem:Sensor,

INFIL2M3,                !- Name
2F,                      !- Output:Variable or Output:Meter Index Key Name
Zone Infiltration Current Density Volume Flow Rate;  !- Output:Variable or Output:Meter Name

EnergyManagementSystem:Actuator,
  Infil1setM3,             !- Name
  SPACE-1 INFIL 1,         !- Actuated Component Unique Name
  Zone Infiltration,       !- Actuated Component Type
  Air Exchange Flow Rate;  !- Actuated Component Control Type

EnergyManagementSystem:Actuator,
  Infil2setM3,             !- Name
  SPACE-2 INFIL 1,         !- Actuated Component Unique Name
  Zone Infiltration,       !- Actuated Component Type
  Air Exchange Flow Rate;  !- Actuated Component Control Type

EnergyManagementSystem:Program,
  Determine_infiltration,  !- Name
  SET ORIGINALINFIL1=INFIL1,  !- Program Line 1
  SET ORIGINALINFIL2=INFIL2,  !- Program Line 2
  IF VRFMODE > 0,          !- A4
  SET set1=@min 0.0918 infil1M3,  !- A5
  SET set2= @min 0.0918 infil2M3,  !- A6
  elseif VRFMODE == 0,     !- A7
  SET set1= infil1M3,        !- A8
  SET set2= infil1M3,        !- A9
  ENDIF,                   !- A10
  set infil1setM3=set1,    !- A11
  set infil2setM3=set2;    !- A12

It seems to output an uncontrolled large amount of infiltration through the infil-reset program in EMS, which may be affected by zonethermalchimney object. And, I have searched the internet and cannot find any useful suggestion.image description

edit retag flag offensive close merge delete

Comments

I assume that there is one thermal chimney object for both Zones (1F and 2F)? Could you add plots to your post, or links to plot images, to better illustrate the issue that you're having? What makes you think that the EMS program outputs "an uncontrolled large amount of infiltration"?

Aaron Boranian gravatar imageAaron Boranian ( 2018-10-30 08:38:25 -0500 )edit

The idf segment above is not enough to diagnose this, as it does not include the calling point or the definitions of infil1M3 and infil2M3. The edd output file will show the results of every EMS program line, so you should be able to diagnose this by looking there. Also note that the "Air Exchange Flow Rate" actuator is in [m3/s], not [ACH]. If you cannot resolve this, please post a link to the full idf file here or send to the helpdesk at energyplus-support@gard.com

MJWitte gravatar imageMJWitte ( 2018-10-30 14:10:30 -0500 )edit

Thanks so much for your advice, I have reattached the sensor infil1M3, infil2M3.The vertical thermal chimney has objected to 1f and 2f. Here are the more detail for my model and the output of infiltration. And I found in .rdd file, EnergyManagementSystem:Actuator Available,SPACE-2 INFIL 1,Zone Infiltration,Air Exchange Flow Rate,[m3/s]

shellyhong gravatar imageshellyhong ( 2018-10-30 21:34:33 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-10-31 16:11:02 -0500

The Determine_infiltration EMS program above is circular, leading to the high infiltration rate. This program is being called from BeginTimestepBeforePredictor. At that point, the sensors infil1M3 and infil2M3 hold the value of infiltration at the end of the prior timestep - they do not represent the unmodified infiltration rate for the current timestep. In fact, the infiltration rate for the current timestep has not been calculated yet. Use the Null value to set an actuator to take no action. This program results in reasonable infiltration rates.

EnergyManagementSystem:Program,
Determine_infiltration,  !- Name
SET ORIGINALINFIL1=INFIL1,  !- Program Line 1
SET ORIGINALINFIL2=INFIL2,  !- Program Line 2
IF VRFMODE > 0,          !- A4
SET infil1setM3=@min 0.0918 infil1M3,  !- A5
SET infil2setM3= @min 0.0918 infil2M3,  !- A6
elseif VRFMODE == 0,     !- A7
SET infil1setM3= Null,      !- A8
SET infil2setM3= Null,      !- A9
ENDIF;                   !- A10

Also, you should make a second EnergyManagementSystem:ProgramCallingManager object to call the Determine_DOAS program (not shown above) later in the simulation after the infiltration has been calculated using the impact of the first EMS program. Use calling point AfterPredictorBeforeHVACManagers or InsideHVACSystemIterationLoop. You may need to experiment to see which one gives the best result.

edit flag offensive delete link more

Comments

Thanks so much for your kind suggestion. It indeed helps me a lot and gives me a reasonable output for zone infiltration. Now I have made two ems:callingmanager object and try both calling point you recommended. But, after I check the .edd file, it seems the EnergyManagementSystem: Actuator Available, zone infiltration cannot override the original infiltration output. From the EMS guide, I notice the zone infiltration actuator only control the infiltration zone-by-zone, not outdoor environment. Is this the reason for the unsuccess? or just I still have mistakes in my program calling?

shellyhong gravatar imageshellyhong ( 2018-11-01 10:39:54 -0500 )edit

After some test runs and some searching in the code, I think I see the problem. The EMS actuator for Zone Infiltration only impacts the infiltration flow calculated by the ZoneInfiltration:* objects. The thermal chimney adds induced infiltration to the base infiltration rate and the total is reported in "Zone Infiltration Current Density Volume Flow Rate". The thermal chimney has no EMS actuator, but you can turn off the thermal chimney by actuating it's Schedule Value to zero. The reported chimney volume flow rate will be zero, but the infiltration flow should be correct.

MJWitte gravatar imageMJWitte ( 2018-11-02 07:25:39 -0500 )edit

New issue #7044 posted to clarify the chimney-infiltration connection in the documentation, and possibly add new EMS actuators for the chimney.

MJWitte gravatar imageMJWitte ( 2018-11-02 09:10:02 -0500 )edit

Thanks, I will try the new method.

shellyhong gravatar imageshellyhong ( 2018-11-02 09:30:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 



Question Tools

1 follower

Stats

Asked: 2018-10-29 21:36:20 -0500

Seen: 77 times

Last updated: Oct 31 '18