OpenStudio Plugin error visualizing surfaces

asked 2018-10-08 04:31:32 -0500

NunoSaraiva gravatar image

updated 2018-10-08 09:46:20 -0500

Hello everyone, I was working on my model and saved it normally. When I tried to open the file again to continue, Sketchup did not show me any surface even when I open the OpenStudio Inspector and the surfaces are there. I have already tried to run the OSM Diagnostic Script which gives me this:

Model has 0 objects

Model has 0 thermal zones

Model has 0 spaces

Model has 0 base surfaces

Model has 0 sub surfaces

Model has 0 shading surfaces

Model has 0 interior partition surfaces

I do not understand why this is happening since no errors are detected. Hope someone can help. Best regards, Nuno Saraiva

edit retag flag offensive close merge delete

Comments

Did you save the .osm file or just the .skp file?

__AmirRoth__ gravatar image__AmirRoth__ ( 2018-10-08 09:47:10 -0500 )edit

I saved the .osm file and if I open it with OpenStudio the file is ok (the geometry is correct). The problem is I want to continue the geometry and I can not since there are no surfaces.

NunoSaraiva gravatar imageNunoSaraiva ( 2018-10-08 09:49:00 -0500 )edit

Cross posting of https://github.com/NREL/OpenStudio/is.... Unless you know for sure it's a bug, posting on UnmetHours first (and only) is preferred, thank you!

Julien Marrec gravatar imageJulien Marrec ( 2018-10-08 09:49:43 -0500 )edit

To achieve the fastest resolution possible, could you host your file somewhere (google drive, box, wetransfer, whatever) and add a link here?

Julien Marrec gravatar imageJulien Marrec ( 2018-10-08 09:50:57 -0500 )edit

@NunoSaraiva when you say geometry looks fine in OpenStudio, do you mean OS app, geometry tab? Try launching SketchUp, then use the OSM Open, without opening a SKP file. Does that work? If it does use the SaveAs in OpenStudio file toolbar to save the OSM as a new name. Now turn off auto-save in SketchUp and then open the SKP file. Doing this may clear away OSM content as it is making a new OSM. Now re-load the OSM file using the OpenStudio toolbar. You should have the OSM and SKP content both visible. Don't the SKP file while the OSM is still open. Let me know if this works.

David Goldwasser gravatar imageDavid Goldwasser ( 2018-10-08 10:58:09 -0500 )edit