Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question

Sensible Cooling Load present even with Very High Cooling Setpoint

asked 2018-09-13 11:06:47 -0500

gmge25 gravatar image

updated 2018-10-03 09:58:12 -0500

I have read from several sources that in Energyplus a way to switch off the cooling is to set the cooling thermostat setpoint at a very high value.

I used this trick in order to simulate the DOE's small office prototype for 3 winter months with the HVAC in heating only mode, with heating setpoint changing randomly between one very high, (heating should be at full power) and one very low (heating should be completely off). In order to do so, I used E+ together with BCVTB and MATLAB.

However, in the csv output I see that the cooling is still active quite often, and it seems to be turned on during daylight when the heating setpoint is set at its lowest value. In other words, it is like the cooling is pushing the zones temperature towards the lowest heating setpoint. (I am measuring its activity from the Zone System Sensible Cooling Rate output variable).

I tried several the setpoints values (5-30 for heating, 40 for cooling; 5-50 for heating, 60 for cooling), different weather files, but the cooling still works. I have also tried to change the thermostat setpoint from DualSetPoint to SingleHeating, which according to the documentation is "Used for a heating only thermostat. The setpoint can be scheduled and varied throughout the simulation but only heating is allowed with this control type.". But the problem still remains.

Am I missing something? I guess so, because the trick is quite common, I read it also in other questions in this forum.

Thank you in advance for any contribution.

edit retag flag offensive close merge delete


@gmge25 May be your problem is the cooling set-point which lowering the building temperature too much. Anyway I recommend on using Availability Manager.

Avi gravatar imageAvi ( 2018-09-14 12:39:34 -0500 )edit

Thanks for the reply. The point is, with a cooling setpoint of 60° (celsius!), cooling mode will not be present even in a desert. I used weather files from Los Angeles and San Francisco.

I will check out the Availability Manager, seems neat.

gmge25 gravatar imagegmge25 ( 2018-09-20 10:15:37 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2018-09-14 15:01:51 -0500

"Zone Air System Sensible Cooling Rate" (along with all other output variables) is defined in the Input Output Reference. This one is often confused as to its meaning, so there's an extra note:

Zone Air System Sensible Heating (and Cooling) Energy (and Rate) all report the heating or cooling delivered by the HVAC system to a zone. These values are calculated by multiplying the supply air mass flow rate by the difference between the supply air temperature and the zone air temperature. This does not always indicate the operation of heating or cooling coils. For example, cooling will be reported if the supply air is cooled due to the introduction of outside air, even if all coils are off.

The small office prototype likely has continuous fan operation with outdoor air during occupied hours, thus lots of free cooling will be supplied in a space that's not actively cooled. Report "Cooling Coil Total Cooling Rate" to see if there's actually mechanical cooling happening.

edit flag offensive delete link more


I switched off the fans and it worked: sensible cooling load dropped to zero. Thanks! From time to time the cooling coil total cooling rate is greater than zero, for very short periods of time and with quite low values (<80W), in correspondence with heating in off mode after periods of prolonged heating, but I guess it is part of how the hvac works?

gmge25 gravatar imagegmge25 ( 2018-09-20 10:12:48 -0500 )edit

No, it's not just "how the hvac works". It's likely due to the use of SetpointManager:SingleZone:Reheat in that model. That's no longer best practice for EnergyPlus and can cause some anomalies. It's better to use separate ...SingleZone:Cooling and ...SingleZone:Heating, one for each coil. Also, you haven't mentioned which version of EnergyPlus you are running, there was a fix to this particular setpoint manager in v8.4 (Sep 2015).

MJWitte gravatar imageMJWitte ( 2018-09-24 16:44:06 -0500 )edit

I use the v8.9.0. Changing the setpoint as you suggested eliminated the cooling rate completely, good! However, I have just noticed that not all the times the heating setpoint is set high the heating is working...this started after I switched off the fans (at the time I asked the question from this point of view the simulation was fine). Thank you for the patience, I am quite new to the field.

gmge25 gravatar imagegmge25 ( 2018-09-26 10:56:56 -0500 )edit

I'm not sure I follow the heating question. Just a guess - you need to use different nodes for the separate SingleZone:Heating and SingleZone:Cooling setpoints. See the expidf file for example file SmOffPSZ-MultiModeDX.

MJWitte gravatar imageMJWitte ( 2018-10-04 14:49:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer


Question Tools

1 follower


Asked: 2018-09-13 11:06:47 -0500

Seen: 71 times

Last updated: Sep 14 '18