Resstock cannot locate measure

asked 2018-09-12 08:52:51 -0500

Vishak gravatar image

updated 2018-09-19 04:54:12 -0500

Hello all,

I am trying to run a sample resstock model 'project_resstock_national' following the due instructions on the website. I am repeatedly running into an error ' Cannot find seed model'. The seed model is clearly getting exported to the simulation zip file PAT fails to locate it or utilize it.

Where might be the error? I am using AMI 2.2.1-Is0 as instructed in the tutorial.

edit retag flag offensive close merge delete

Comments

Can you try using the 2.6.0 AMI?

shorowit gravatar imageshorowit ( 2018-09-12 09:10:36 -0500 )edit

I didn't have success with 2.6.0 AMI either. Also I am unable to start c3.8x large and c3.4x large instances. the instances start on AWS but PAT loses connectivity displaying the message ' error starting sever'. However I can run c3.2x large instances perfectly, but the solution fails every time. I got a perfectly running file from my acquaintance to test where the fault lies. The file that completed sims on his computer did not run on my computer. I have switched between 2.6.0, 2.2.1 and 2.5.0 AMIs. Using openstudio PAT version 2.4.0 and windows 10.

Vishak gravatar imageVishak ( 2018-09-17 08:34:26 -0500 )edit

I'm not sure why you can't start certain instances. But we've been doing runs using PAT version 2.6.0 as well as AMI version 2.6.0.

Also, when you say you didn't have success with the 2.6.0 AMI, do you get the same error "Cannot find seed model" or is there a different error?

shorowit gravatar imageshorowit ( 2018-09-18 15:47:50 -0500 )edit

Hi, I downloaded and installed PAT OS 2.6.0 and got the clusters running but the datapoints still fail. the error is with 'BuildExistingModel' measure. inserting the error text in the comment:

[09:35:44.721784 ERROR] /usr/local/lib/ruby/gems/2.2.0/gems/openstudio-workflow-1.3.3/lib/openstudio/workflow/util/measure.rb failed with message cannot load such file -- /mnt/openstudio/analysis_963d7a45-23b4-4cee-815e-5017c198ec2e/lib/resources/buildstock in /usr/local/lib/ruby/gems/2.2.0/gems/activesupport-5.1.4/lib/active_support/dependencies.rb:292:in `require'

Vishak gravatar imageVishak ( 2018-09-19 04:40:33 -0500 )edit

From other questions that I looked up on Unmethours, I searched for 'yamlFilename' in pat.json. the value there is still 'jrobert'. while some people had mentioned that it should have been a path name. Is that another problem that I might be facing?

thanks

Vishak gravatar imageVishak ( 2018-09-19 04:49:32 -0500 )edit