Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question

Solar Data Discrepancies xEso Excel

asked 2018-08-08 04:11:49 -0500

Neewby's avatar

updated 2018-08-08 10:41:26 -0500


I'm in a kind of trouble right now concerning a E+ data analysis, in terms of the Solar Radiation "Surface Outside Face Incident Beam Solar Radiation Rate per Area". After simulation I got the following xEso analysis, so the diagram shows a "U". After that I copied the data with ctrl + c to gather the dates with numbers in a excel sheet for visualization. But my Excel Diagram tool gave me a complete different course of the diagram, it's straight and not a "U". Even the maximum values are incorrect so I assume that it's a different data set that I copied. I've tried this several times and it worked well with the "Site Diffuse Solar Radiation Rate per Area" but not with the intended surface.

Unfortunately I am unable to show some pictures here right now.

Any advise? Thank you!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2018-08-09 13:30:55 -0500

I do not have any experience copying/pasting from xEsoView. I use the csv output directly in a spreadsheet. On Windows with EPLaunch, this is created automatically using the ReadVarsESO post-processor. On other platforms, I believe this is also automatically part of the run scripts.

edit flag offensive delete link more


Thank you for your advise! After looking at the csv, I found that all of my (over 70) output parameters are in a single Excel cell and separated by a comma. I've tried using the "OutputControl: Table: Style" to change this setting to "Tab" to get the parameters sorted into individual cells, which unfortunately did not work. An evaluation would be much easier in that way.

Neewby's avatar Neewby  ( 2018-08-11 14:36:52 -0500 )edit

EnergyPlus output files are written using the North American convection of point (.) as the decimal symbol and comma as the list separator. Users in other regions likely have to modify their system regional settings to read EnergyPlus csv files correctly in Excel. I'm fairly certain this is necessary so that the decimal points written by EnergyPlus in the values are interpreted correctly. Other users may have a better solution to suggest.

OutputControl:Table:Style only affects the table outputs.

MJWitte's avatar MJWitte  ( 2018-08-13 10:28:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops

Question Tools

1 follower


Asked: 2018-08-08 04:11:49 -0500

Seen: 175 times

Last updated: Aug 09 '18