Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

OpenStudio failure

asked 2018-06-30 12:34:34 -0500

mfath's avatar

Hi,

I am trying to model a primary school in OpenStudio. However, it fails when I am trying to run the unconditioned space. The ERR file and failure snapshot are presented in the following URL. I will appreciate that if you can help me with that.

https://drive.google.com/drive/folder...

Thanks,

edit retag flag offensive close merge delete

Comments

@M 108014 have you manually deleted objects from that OSW file? Could you post a link to that model?

Avi's avatar Avi  ( 2018-07-02 01:38:38 -0500 )edit

@Avi No, I did not delete any object manually from the OSW file. Please find attached the link to the model

https://drive.google.com/drive/folder...

Thanks,

mfath's avatar mfath  ( 2018-07-02 10:09:47 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-07-02 11:16:39 -0500

Avi's avatar

OK I Think you hit on a bug. First you have a space that is not assigned to a thermal zone (Space 1 - 1) but that is not the issue. When I tried running your model after deleting Space 1 - 1, on OS 2.5.1 I got that fatal:

 ** Severe  ** CalcCoordinateTransformation: Invalid dot product, surface="FACE 39":
   **   ~~~   **  (  64.008,   8.839,   0.000)
   **   ~~~   **  (  64.008,  42.672,   0.000)
   **   ~~~   **  (  64.008,  42.672,   0.000)
   **   ~~~   **  (  64.008,  51.511,   0.000)

Which means that the model as overlapping vertices in surface Face 39. as you can read. Your original OSW file doesn't have it:

OS:Surface,
  {3c8b133f-2575-4c50-bef6-f23c74d21342}, !- Handle
  Face 39,                                !- Name
  Floor,                                  !- Surface Type
  ,                                       !- Construction Name
  {da039815-96c8-4a86-8c73-761d436691c1}, !- Space Name
  Ground,                                 !- Outside Boundary Condition
  ,                                       !- Outside Boundary Condition Object
  NoSun,                                  !- Sun Exposure
  NoWind,                                 !- Wind Exposure
  ,                                       !- View Factor to Ground
  ,                                       !- Number of Vertices
  76.8096, 51.5112, 0,                    !- X,Y,Z Vertex 1 {m}
  76.8096, 8.8392, 0,                     !- X,Y,Z Vertex 2 {m}
  64.008, 8.8392, 0,                      !- X,Y,Z Vertex 3 {m}
  64.008, 51.5112, 0;                     !- X,Y,Z Vertex 4 {m}

It shows up in the in.osw generated only during simulation :

OS:Surface,
  {3c8b133f-2575-4c50-bef6-f23c74d21342}, !- Handle
  Face 39,                                !- Name
  Floor,                                  !- Surface Type
  ,                                       !- Construction Name
  {da039815-96c8-4a86-8c73-761d436691c1}, !- Space Name
  Ground,                                 !- Outside Boundary Condition
  ,                                       !- Outside Boundary Condition Object
  NoSun,                                  !- Sun Exposure
  NoWind,                                 !- Wind Exposure
  ,                                       !- View Factor to Ground
  ,                                       !- Number of Vertices
  64.008, 8.8392, 0,                      !- X,Y,Z Vertex 1 {m}
  64.008, 11.8872, 0,                     !- X,Y,Z Vertex 2 {m}
  64.008, 21.0312, 0,                     !- X,Y,Z Vertex 3 {m}
  64.008, 30.7848, 0,                     !- X,Y,Z Vertex 4 {m}
  64.008, 39.624, 0,                      !- X,Y,Z Vertex 5 {m}
  64.008, 42.672, 0,                      !- X,Y,Z Vertex 6 {m}
  64.008, 51.5112, 0,                     !- X,Y,Z Vertex 7 {m}
  76.8096, 51.5112, 0,                    !- X,Y,Z Vertex 8 {m}
  76.8096, 8.8392, 0;                     !- X,Y,Z Vertex 9 {m}

And then being translated into the in.idf:

BuildingSurface:Detailed,
  Face 39,                                !- Name
  Floor,                                  !- Surface Type
  ExtSlabCarpet 4in ClimateZone 1-8,      !- Construction Name
  Corridor 04,                            !- Zone Name
  Ground,                                 !- Outside Boundary Condition
  ,                                       !- Outside Boundary Condition Object
  NoSun,                                  !- Sun Exposure
  NoWind,                                 !- Wind Exposure
  ,                                       !- View Factor to Ground
  ,                                       !- Number of Vertices
  64.008, 8.8392, 0,                      !- X,Y,Z Vertex 1 {m}
  64.008, 11.8872, 0,                     !- X,Y,Z Vertex 2 {m}
  64.008, 21.0312, 0,                     !- X,Y,Z Vertex 3 {m}
  64.008, 30.7848, 0,                     !- X,Y,Z Vertex 4 {m}
  64.008, 39.624, 0,                      !- X,Y,Z Vertex 5 {m}
  64.008, 42.672, 0,                      !- X,Y,Z Vertex 6 {m}
  64.008, 51.5112, 0,                     !- X,Y,Z Vertex 7 {m}
  76.8096, 51.5112, 0,                    !- X,Y,Z Vertex 8 {m}
  76.8096, 8.8392, 0;                     !- X,Y,Z Vertex 9 {m}

I believe that this bug was already reported here and got to do with the geometry editor.

I was able to work ... (more)

edit flag offensive delete link more

Comments

@David Goldwasser You might wan't to look at that as I believe it is related to a close issue linked above

Avi's avatar Avi  ( 2018-07-02 14:38:57 -0500 )edit

@Avi as you mentioned, I deleted Space 1-1, and I changed the number of vertices to 4 for Face 39. However, when I tried to run it in OS 2.5, it did not work and I got the following error message.

https://drive.google.com/file/d/1n0Cf...

mfath's avatar mfath  ( 2018-07-02 22:00:38 -0500 )edit

@M 108014 Look carfully as you might misstyped something in the file

Avi's avatar Avi  ( 2018-07-03 04:18:19 -0500 )edit

@Avi Thanks for your help. I checked the files again. It seems that in my OS file, Face 47 creates problem (as attached in the ERR file). However, I also checked the following files:

CheckPoint2.osm in.osm in.idf

In all of them, for Face 47, I have 8 vertices. should I delete 4 vertices from the CheckPoint2.osm file? or is there any other file that I need to check and make changes to them?

https://drive.google.com/drive/folder...

mfath's avatar mfath  ( 2018-07-03 09:52:09 -0500 )edit

If you look at your original CheckPoint2.osm file the Face 47 looks like that:

  64.008, 51.5112, 3.9624,                !- X,Y,Z Vertex 1 {m}
  76.8096, 51.5112, 3.9624,               !- X,Y,Z Vertex 2 {m}
  76.8096, 51.5112, 0,                    !- X,Y,Z Vertex 3 {m}
  64.008, 51.5112, 0;                     !- X,Y,Z Vertex 4 {m}

So something you did changed it try to reload the original file the one in that link and try to find out when dose it changes.

Avi's avatar Avi  ( 2018-07-03 12:18:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops

Careers

Question Tools

1 follower

Stats

Asked: 2018-06-30 12:34:34 -0500

Seen: 427 times

Last updated: Jul 02 '18