Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
2

How to set VAV mass flow rates by EMS?

asked 2018-06-23 23:37:06 -0600

TomB gravatar image

updated 2018-07-07 10:38:00 -0600

Any guidance on how can I use an EMS program to override behaviour of a setpoint manager in heating mode, to increase airflow rate through each VAV up to maximum available would be helpful.

My goal is to create an EMS program that increases VAV airflow rates up to their maximum available so that there is more hot air during morning warmup. The problem I am having is that the zones are taking ~3 hours to warm up because they are not getting enough hot air. The reheat coils are working, delivering hot air, but the flow rates are stuck on min.

I am using a SetpointManager:WarmestTemperatureFlow

  • Temperature first
  • Minimum TurndownRatio 0.35

From the docs, In heating mode, this SPM will set minimum flow:

 "...For TemperatureFirst the manager tries to find the highest setpoint temperature that will satisfy all the zone cooling loads at minimum supply air flow rate. If this setpoint temperature is less than the minimum, the setpoint temperature is set to the minimum, and the supply air flow rate is increased to meet the loads... ""

The .edd tells me that there is no Actuator for 'Minimum Airflow Ratio'. Best I can do is Mass Flow Rate or Minimum Available Mass Flow Rate. My attempts so far have failed to achieve the desired outcome using these actuators (on both AirLoop supply outlet node and also an AirTerminal supply node).

Can someone familiar with the inner working of the HVAC code comment on how the code takes the value for the 'Minimum Turndown Ratio' set in the SPM and from it sets the VAV flow rates? Links to the source code that does this would be helpful.

Screenshot of the AirLoop image description

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-07-06 02:13:30 -0600

Instead of directly manipulating mass flow rates, I would propose using Minimum Air Flow Fraction Schedule(s) for AirTerminal:SingleDuct:VAV:Reheat (or ...:noReheat), as shown below:

image description

(1) Setup Minimum Air Flow Fraction Schedules as Schedule:Constant

(2) Modify the schedule values according to your criteria by EMS instructions

edit flag offensive delete link more

Comments

ill check this out thanks

TomB gravatar imageTomB ( 2018-07-06 02:23:56 -0600 )edit

did it work for you ?

OS-user-AT gravatar imageOS-user-AT ( 2018-07-09 02:37:11 -0600 )edit

no, it didn't work. The SetpointManager dominates the terminal minimum turndowns.

TomB gravatar imageTomB ( 2018-07-09 21:24:43 -0600 )edit

Did you change the Zone Minimum Air Flow Input Method to Scheduled ?

OS-user-AT gravatar imageOS-user-AT ( 2018-07-20 11:20:05 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2018-06-23 23:37:06 -0600

Seen: 159 times

Last updated: Jul 06 '18