Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
2

Measure Manager has crashed

asked 2018-06-02 10:23:56 -0600

Saroop gravatar image

updated 2018-06-02 14:54:28 -0600

OpenStudio 2.5.0 crashes when I drag and drop a measure. This crash only occurs after the .osm file has been edited in sketchup.

Can someone help me understand this error message? I tried to go to the path mentioned ( C:\Git\OS\openstudiocore\src\energyplus\ForwardTranslator\CreateAirLoopHVACSupplyPath.cpp ) but it doesn't exist on my computer.


Measure Manager has crashed

Measure Manager has crashed, attempting to restart

[2018-06-01 23:30:07] INFO WEBrick 1.3.1

[2018-06-01 23:30:07] INFO ruby 2.2.4 (2015-12-16) [x64-mswin64_120]

[2018-06-01 23:30:07] INFO WEBrick::HTTPServer#start: pid=7672 port=51266

Barracuda-PC - - [01/Jun/2018:23:35:41 Pacific Daylight Time] "POST /bcl_measures HTTP/1.1" 200 17550 - -> /bcl_measures

Barracuda-PC - - [01/Jun/2018:23:35:43 Pacific Daylight Time] "POST /update_measures HTTP/1.1" 200 2 - -> /update_measures

Barracuda-PC - - [01/Jun/2018:23:36:13 Pacific Daylight Time] "POST /bcl_measures HTTP/1.1" 200 17550 - -> /bcl_measures

Barracuda-PC - - [01/Jun/2018:23:36:13 Pacific Daylight Time] "POST /update_measures HTTP/1.1" 200 2 - -> /update_measures

[BOOST_ASSERT] <2> Assertion splitters.size() == 1u failed on line 70 of class boost::optional<class openstudio::idfobject=""> __cdecl openstudio::energyplus::ForwardTranslator::createAirLoopHVACSupplyPath(const class openstudio::model::Node &) in file C:\Git\OS\openstudiocore\src\energyplus\ForwardTranslator\CreateAirLoopHVACSupplyPath.cpp.

[utilities.bcl.BCLXML] <2> 'C:/Users/saroop/BCL/67931e1a-bff1-4da2-97c9-577f0daecc40/775c82e9-e9c5-49d1-95c3-ecd79be30851/measure.xml' does not exist

[utilities.bcl.BCLMeasure] <2> 'C:/Users/saroop/BCL/67931e1a-bff1-4da2-97c9-577f0daecc40/775c82e9-e9c5-49d1-95c3-ecd79be30851' is not a measure

[utilities.bcl.BCLXML] <2> 'C:/Users/saroop/BCL/67931e1a-bff1-4da2-97c9-577f0daecc40/775c82e9-e9c5-49d1-95c3-ecd79be30851/measure.xml' does not exist

[utilities.bcl.BCLMeasure] <2> 'C:/Users/saroop/BCL/67931e1a-bff1-4da2-97c9-577f0daecc40/775c82e9-e9c5-49d1-95c3-ecd79be30851' is not a measure

[openstudio.model.CoilCoolingWater] <1> Required availability schedule not set, using 'Always On' schedule [openstudio.model.CoilCoolingWater] <1> Required availability schedule not set, using 'Always On' schedule [openstudio.model.CoilCoolingWater] <1> Required availability schedule not set, using 'Always On' schedule [openstudio.model.CoilCoolingWater] <1> Required availability schedule not set, using 'Always On' schedule [openstudio.model.CoilCoolingWater] <1> Required availability schedule not set, using 'Always On' schedule [openstudio.model.CoilCoolingWater] <1> Required availability schedule not set, using 'Always On' schedule

[BOOST_ASSERT] <2> Assertion splitters.size() == 1u failed on line 70 of class boost::optional<class openstudio::idfobject=""> __cdecl openstudio::energyplus::ForwardTranslator::createAirLoopHVACSupplyPath(const class openstudio::model::Node &) in file C:\Git\OS\openstudiocore\src\energyplus\ForwardTranslator\CreateAirLoopHVACSupplyPath.cpp.

edit retag flag offensive close merge delete

Comments

I've reduced part of the error message by redownloading the Replace Thermostat Schedules

Saroop gravatar image Saroop  ( 2018-06-03 20:52:23 -0600 )edit

OpenStudio is crashing because you have an AirLoopHVAC that has more than one splitter, which should never happen (there should be only one splitter, on the demand side)

Julien Marrec gravatar image Julien Marrec  ( 2018-06-04 08:28:35 -0600 )edit

also, delete and re-download this measure: C:/Users/saroop/BCL/67931e1a-bff1-4da2-97c9-577f0daecc40/775c82e9-e9c5-49d1-95c3-ecd79be30851

mdahlhausen gravatar image mdahlhausen  ( 2018-06-05 11:04:24 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-02-24 11:57:16 -0600

Gubbagubba gravatar image

Hi! Did you figure out this problem? I can't get OpenStudio to open. I am getting the first two lines of error regarding WEBrick and Ruby 2.2.4 also.
I just uninstalled in reinstalled OpenStudio. I uninstalled Sketchup. I rebooted the computer, and I am still getting the same error. I am surprised by this.

edit flag offensive delete link more

Comments

Ah! I hand too many construction libraries! OpenStudio finally opened after 20 minutes. I then unloaded the libraries through the Preferences tab on top! It is back to normal and running smoothly again.

Gubbagubba gravatar image Gubbagubba  ( 2019-02-24 12:56:09 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2018-06-02 02:12:47 -0600

Seen: 432 times

Last updated: Jun 02 '18