Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
2

EnergyPlus schedule file

asked 2018-05-30 09:57:54 -0600

M 108014 gravatar image

updated 2018-05-30 16:38:24 -0600

I have the internal loads schedule on a minute base for a house for three months (June-August). I use this one-minute schedule in EnergyPlus "Schedule: File" section. Just to check if I am applying the schedule correctly, I report the "schedules value" for that particular schedule. However, the output is different for some time spots. I would appreciate that if someone can help me, because it stopped me for more than one month.
Please find attached the .idf file, schedule file, and weather file. I also attached the output file that I have after simulation.

https://drive.google.com/drive/folder...

edit retag flag offensive close merge delete

Comments

It seems that the problem in one-minute schedule happens between 23:00 - 24:00 and when I apply hourly schedule it happens at 24:00.

M 108014 gravatar imageM 108014 ( 2018-05-30 14:57:41 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
5

answered 2018-06-01 15:24:38 -0600

The discrepancy is due to daylight savings time. (And there are differences for many hours during the summer, not just near midnight.) Delete this object and the values will align perfectly:

RunPeriodControl:DaylightSavingTime,
April 7,                 !- Start Date
October 26;              !- End Date

If this is measured data, then you want DST to be off, because it's likely in synch with the sun using standard time. If this is calculated data, then you might want the values to be shifted for DST, but that can get confusing.

edit flag offensive delete link more
0

answered 2018-05-30 18:32:23 -0600

M 108014 gravatar image

I applied all your comments on the file, and still have the same issue in the schedules. I uploaded the files that I used earlier based on your comment and also the output.csv file. I am observing one - hour forward shift in the output schedule that I am exporting. Also, if I realign the data manually, still there are intervals that those input and output schedules are not the same.

https://drive.google.com/drive/folder...

In the 1minSchedule file which I am trying to reach that. From beginning the 0.0001 values that I have in that file are only because not to use zero value there. The only data that I have is from Jun-Aug.

edit flag offensive delete link more

Comments

You still have "Schedule Name" filled in for your output variable, don't include it. Even without that, I still see a discrepancy that I cannot explain.

Julien Marrec gravatar imageJulien Marrec ( 2018-05-31 03:35:16 -0600 )edit

The "funny" thing is that if I create a MCVE with the 1ZoneUncontrolled.idf example file (just adding your schedule file, the output variable, changing the timestep to 60, and not running for Sizing periods), it works perfectly...

Julien Marrec gravatar imageJulien Marrec ( 2018-05-31 03:43:10 -0600 )edit

See the MCVE here. All modifications are at the end of the file (line 400 and following).

Julien Marrec gravatar imageJulien Marrec ( 2018-05-31 04:17:09 -0600 )edit

I'd tend to say you should send a ticket to http://energyplus.helpserve.com/ explaining your problem and linking to this conversation.

Julien Marrec gravatar imageJulien Marrec ( 2018-05-31 04:25:30 -0600 )edit

@Julien Marrec Thanks for your helps. I checked the directory that you sent and you are right. It works there with the mentioned modifications. I submitted a ticket. Thanks again.

M 108014 gravatar imageM 108014 ( 2018-05-31 09:56:58 -0600 )edit
0

answered 2018-05-30 15:20:43 -0600

updated 2018-05-30 18:00:07 -0600

(It would have been helpful to see a graph showing the discrepancy).

Anyways, from a cursory look I'd say your Output:Variable is wrong. Here's what you have:

Output:Variable,
    *,                       !- Key Value
    Schedule Value,          !- Variable Name
    Timestep,                !- Reporting Frequency
    MiscElecLoad_1;          !- Schedule Name

I suspect you don't understand what Schedule Name actually does. See the I/O Reference Guide, but in short:

The output variable will be active during any hour in which the schedule value is >0

If you want to report only one schedule named MiscElecLoad_1 you should do it like so:

Output:Variable,
    MiscElecLoad_1,          !- Key Value
    Schedule Value,          !- Variable Name
    Timestep;                !- Reporting Frequency

Edit:

I loaded your 1minSchedule.csv file using Python (with pandas), and I filtered it to find the timestamps where you have a 0 value, meaning the Output:Variable doesn't report. It happens for only 6 values, all of which are around 23:30:

2005-06-12 23:32:00    0.0
2005-06-12 23:33:00    0.0
2005-06-12 23:34:00    0.0
2005-06-12 23:35:00    0.0
2005-06-12 23:36:00    0.0
2005-06-12 23:37:00    0.0

So that explains your problem between 23 and 24.


Edit 2:

In the output you show, you never include the timestamp, but your SimulationControl has Run Simulation for Sizing Periods:

  SimulationControl,
    Yes,                     !- Do Zone Sizing Calculation
    No,                      !- Do System Sizing Calculation
    Yes,                     !- Do Plant Sizing Calculation
    No,                      !- Run Simulation for Sizing Periods
    Yes;                     !- Run Simulation for Weather File Run Periods

This means that your eplusout.csv will include, at the top, data for your sizing periods. This could cause an offset when you are comparing stuff.

I did test do dummy example hourly schedule that I added to the example file 1ZoneUncontrolled.idf and I got this misalignment schedule initially (actually I found it because the output length was not 8760 but 8808 since I had two design days in my file (8670 + 2*24hrs = 8808).

After realigning the data (or just not run it for Sizing Periods), the input matches the output perfectly.

edit flag offensive delete link more

Comments

You are right @Julien Marrec. But still I can get the schedule output for the key variable that I have. However, there is a discrepancy between (11:00 - 12:00 PM) in one-minute schedule and at 12:00 PM for one-hour schedule input.

M 108014 gravatar imageM 108014 ( 2018-05-30 15:31:07 -0600 )edit

Fix the output:variable like I told you to, and rerun. See if the discrepancy is still there.

Julien Marrec gravatar imageJulien Marrec ( 2018-05-30 15:36:42 -0600 )edit

See my edit, I'm like 99% sure fixing the Output:Variable will remove your discrepancy.

Julien Marrec gravatar imageJulien Marrec ( 2018-05-30 15:44:03 -0600 )edit

I revised the Output:Variable based on your help. I simplified the schedule and I only used hourly schedule. I attached the file. It seems that there is still discrepancy at midnight.

M 108014 gravatar imageM 108014 ( 2018-05-30 16:37:54 -0600 )edit

Please let me know if uploading the hourly schedule is helpful.

M 108014 gravatar imageM 108014 ( 2018-05-30 16:40:47 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2018-05-30 09:57:54 -0600

Seen: 182 times

Last updated: Jun 01