Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

Error importing ESO file

asked 2018-05-17 06:39:08 -0600

Dieuwert gravatar image

updated 2018-05-21 15:12:29 -0600

I can't open my .ESO file with the designbuilder Results Viewer. When i try to open it, the following error appears: 'Error importing ESO file: In ESO header, an interval type is set to 'whenannualreportvariablesrequested', Timestep, Hourly, Dialy, Monthly or Period only allowed.

I made an input file with OpenStudio and modified some material properties with the IDF Editor.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
3

answered 2018-05-17 08:42:42 -0600

EnergyPlus 8.9 added an annual reporting frequency (see here for the changelog), and it looks like that is tripping up the viewer. Do you have any outputs set to report at annual frequency? If so and you're running one year (or less), then change those to run period frequency. If you don't have any output variables with annual reporting frequency, you could try editing the ESO file to delete this line in the header:

6,1,Calendar Year of Simulation[] ! When Annual Report Variables Requested

If neither of those work, it may be that modifications in the code of the viewer are needed.

edit flag offensive delete link more

Comments

Also check if you have used “Detailed” reporting frequency for any of the requested output variables in the INP file. I’ve seen this error due to that.

Molly Curtz gravatar imageMolly Curtz ( 2018-05-17 10:16:27 -0600 )edit

All my outputs where set to hourly but there was indeed something with the update which caused the problem. I installed xEsoView and it worked. Thanks for the fast answer!

Dieuwert gravatar imageDieuwert ( 2018-05-17 12:56:53 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2018-05-17 06:39:08 -0600

Seen: 351 times

Last updated: May 17