Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
5

OpenStudio 2.5 Create DOE Prototype Building

asked 2018-04-09 09:22:00 -0500

Tim Johnson gravatar image

updated 2018-04-09 09:44:49 -0500

The latest OpenStudio 2.5.0 release does not seem to be compatible with the "Create DOE Prototype Building" measure. It doesn't seem to matter which code or building type I pick. Is there a simple fix to the script that would take care of this?

image description

edit retag flag offensive close merge delete

Comments

Are you sure you have the latest version of the measure? The measure on the BCL seems different than the version you are using.

shorowit gravatar image shorowit  ( 2018-04-09 13:16:06 -0500 )edit

@Tim Johnson, sorry for the inconvenience. The openstudio-standards gem was re-factored for OpenStudio 2.5.0 and as a result we need to upload new versions of measures using the gem to the BCL. We will get them tested and posted as soon as we can. I'll post an answer here once the updates are online.

David Goldwasser gravatar image David Goldwasser  ( 2018-04-09 13:20:11 -0500 )edit

That sounds great. Thanks @David Goldwasser.

Tim Johnson gravatar image Tim Johnson  ( 2018-04-09 14:11:28 -0500 )edit

@David Goldwasser do you have an ETA for re-factoring OS Standards measures?

Tim Johnson gravatar image Tim Johnson  ( 2018-04-24 10:21:59 -0500 )edit

@Tim Johnson, we are working on the fix, and expect to have both a 2.5.1. installer and an updated measure on BCL next week. You will need both of them for the fix. One solution you might consider between now and then, if you want to work with 2.5.0 vs. 2.4.0, is to run the measure in OpenStudio 2.4.0 and then load the resulting model into 2.5.0.

David Goldwasser gravatar image David Goldwasser  ( 2018-04-25 11:22:59 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
4

answered 2018-05-07 16:26:39 -0500

An updated version of the Create DOE Prototype Building measure has been added to the BCL.It will not work specifically with 2.5.0, but we have a 2.5.1 installer on our developer page up now.

edit flag offensive delete link more

Comments

This measure still does not work for me, buy maybe I am not understanding the process correctly. I downloaded and extracted the measure into my Measures directory, then used 2.5.1 to "apply measure now." Am I doing that right?

Tim Johnson gravatar image Tim Johnson  ( 2018-05-07 16:53:15 -0500 )edit

@David Goldwasser, I assume this is working on your end, correct? @willy Johan, have you had any luck making this work?

Tim Johnson gravatar image Tim Johnson  ( 2018-05-08 16:12:17 -0500 )edit

@Tim Johnson, there is an issue with the copy on BCL, we should be able to address it tomorrow, sorry that this has taken so long.

David Goldwasser gravatar image David Goldwasser  ( 2018-05-08 17:01:46 -0500 )edit

Thanks for dealing with this, @David Goldwasser. This script and the baseline script are awesome scripts that really help us practitioners. We appreciate them.

Tim Johnson gravatar image Tim Johnson  ( 2018-05-09 09:04:34 -0500 )edit
1

@Tim Johnson, thanks again for your patience, I'm glad you are finding the measures useful. We have fixed the version on the BCL. To make sure you get the most current copy please rename the directory named "BCL" or delete it from your home directory. Then quit and re-launch PAT or the OpenStudio application and re-download the measure.

David Goldwasser gravatar image David Goldwasser  ( 2018-05-10 13:13:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2018-04-09 09:22:00 -0500

Seen: 690 times

Last updated: May 07 '18