Replace Thermostat Schedules - BCL Measure issue

asked 2018-03-21 21:26:45 -0500

hnagda gravatar image

updated 2018-03-21 21:28:39 -0500

I am trying to model a 10,000 sqft office building using OpenStudio. The building currently has an HVAC system (Packaged RTU VAV with reheat) running 24x7 and I want to understand energy savings by implementing a weekday(6am-8pm)/weekend(8am-6pm) schedule.

I ran the model, initially, using constant heating and cooling setpoints for all 7 zones throughout the day to simulate 24x7 HVAC operation, and later, used 'Replace Thermostat Schedules' measure from BCL where I replaced old heating and cooling schedules with revised weekday/weekend schedules for all thermal zones.

The EUI of the model dropped from 170 kBtu/sqft to 70 kBtu/sqft. I found the following warnings in the ERR file:

* Warning * SetUpZoneSizingArrays: Requested Sizing for Zone="THERMAL ZONE 2", Zone has no thermostat (ref: ZoneControl:Thermostat, et al)

* Warning * SetUpZoneSizingArrays: Requested Sizing for Zone="THERMAL ZONE 3", Zone has no thermostat (ref: ZoneControl:Thermostat, et al)

* Warning * SetUpZoneSizingArrays: Requested Sizing for Zone="THERMAL ZONE 4", Zone has no thermostat (ref: ZoneControl:Thermostat, et al)

* Warning * SetUpZoneSizingArrays: Requested Sizing for Zone="THERMAL ZONE 5", Zone has no thermostat (ref: ZoneControl:Thermostat, et al)

* Warning * SetUpZoneSizingArrays: Requested Sizing for Zone="THERMAL ZONE 6", Zone has no thermostat (ref: ZoneControl:Thermostat, et al)

* Warning * SetUpZoneSizingArrays: Requested Sizing for Zone="THERMAL ZONE 7", Zone has no thermostat (ref: ZoneControl:Thermostat, et al)

* Warning * Calculated design cooling load for zone=THERMAL ZONE 2 is zero. * ~~~ * Check Sizing:Zone and ZoneControl:Thermostat inputs.

* Warning * Calculated design heating load for zone=THERMAL ZONE 2 is zero. * ~~~ * Check Sizing:Zone and ZoneControl:Thermostat inputs.

* Warning * Calculated design cooling load for zone=THERMAL ZONE 3 is zero. * ~~~ * Check Sizing:Zone and ZoneControl:Thermostat inputs.

* Warning * Calculated design heating load for zone=THERMAL ZONE 3 is zero. * ~~~ * Check Sizing:Zone and ZoneControl:Thermostat inputs.

* Warning * Calculated design cooling load for zone=THERMAL ZONE 4 is zero. * ~~~ * Check Sizing:Zone and ZoneControl:Thermostat inputs.

* Warning * Calculated design heating load for zone=THERMAL ZONE 4 is zero. * ~~~ * Check Sizing:Zone and ZoneControl:Thermostat inputs.

* Warning * Calculated design cooling load for zone=THERMAL ZONE 5 is zero. * ~~~ * Check Sizing:Zone and ZoneControl:Thermostat inputs.

* Warning * Calculated design heating load for zone=THERMAL ZONE 5 is zero. * ~~~ * Check Sizing:Zone and ZoneControl:Thermostat inputs.

* Warning * Calculated design cooling load for zone=THERMAL ZONE 6 is zero. * ~~~ * Check Sizing:Zone and ZoneControl:Thermostat inputs.

* Warning * Calculated design heating load for zone=THERMAL ZONE 6 is zero. * ~~~ * Check Sizing:Zone and ZoneControl:Thermostat inputs.

* Warning * Calculated design cooling load for zone=THERMAL ZONE 7 is zero. * ~~~ * Check Sizing:Zone and ZoneControl:Thermostat inputs.

* Warning * Calculated design heating load for zone=THERMAL ZONE 7 is zero. * ~~~ * Check Sizing:Zone and ZoneControl:Thermostat inputs.

I ran the same measure in a different model and got similar results and warnings. Is this a problem with the measure or am I missing something in the model? P.S. - There are no warnings for Thermal Zone 1

edit retag flag offensive close merge delete

Comments

It sounds like you have a thermostat in zone 1 but you don't have a thermostat for the other thermal zones. I would also ensure you name each thermal zone and space for ease of reference when you see the results. I would also rerun the measure once you have all the thermostats set up. It would be worth checking that the measure makes the correct changes for cooling and heating set points under schedules. You will also need to ensure that VAV with reheat is set under the HVAC section of openstudio. I believe that there are measures for VAV systems on the building component library

David H gravatar imageDavid H ( 2018-03-25 13:05:37 -0500 )edit

Yes, the error looks like the zones do not have a thermostat but I made sure before the run that all the zones have a thermostat set up, and I also applied the measure to All thermal zones in the model. So the question is that whether the measure is replacing the schedule of only one zone and deleting the schedules of all other zones which renders the zone without a thermostat? If so, then the measure is not working as it's supposed to be.

hnagda gravatar imagehnagda ( 2018-03-27 11:33:24 -0500 )edit