Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
3

parametric analysis tool - openstudio results measure fail

asked 2018-03-16 16:28:32 -0600

updated 2018-03-19 14:02:05 -0600

I am using PAT V2 for OS 2.4. I have a seed model that runs successfully in openstudio alone, a weather file, and I have added a few measures, only one of which I change for my design alternatives. One of the measures I added is the Openstudio Reporting measure, where all of the arguments are set to true. I have created at least measure one option for each measure. All of my design alternatives have a measure option selection for each measure.

When I run the entire workflow I get a status bar which says "Analysis Completed" and for each of the design alternatives the status is "completed Fail" and there are 0 warnings and 0 errors. When I click on the reports tab, under Summary Table it says "The OpenStudio Results measure was not included in Alternative #, cannot show results".

I don't understand why this is happening since I have added the OpenStudio Results measure (from the BCL) and I have created a measure option which sets everything to true and I assign that measure option for every design alternative.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-03-20 18:28:24 -0600

updated 2018-03-20 18:40:21 -0600

Expanding my design alternative in the Run tab, I do not have an EnergyPlus Results report. I also do not have any errors or warnings in my seed model (when run alone in openstudio).

TO FIX THIS ERROR: If you have two copies of the OpenStudio Results measure (one in the BCL and one in your local measure directory) then you need to delete the one in your local directory and run PAT using the one from BCL.

This solves the error, until you try to add a second seed model. When you add another seed model, any measures which rely on components from the original seed model (even if those also exist in your new seed model) will be cleared. i.e. if you have a measure option to change a construction, that measure option will still be there after the new seed model is added, but the construction selection will be cleared. You must reassign all model dependent measure option arguments.

edit flag offensive delete link more
0

answered 2018-03-19 15:23:33 -0600

On the run tab, If the status of a datapoint is "completed Fail" but you value in the red box for errors is "0" and you don't see an error under any measures, then click on "EnergyPlus Results" in the workflow. It will expand to show EnergyPlus warnings and errors. It is likely that your simulation had a fatal error as shown on the example below. Currently warnings and errors directly from EnergyPlus don't roll up to the totals in PAT, only measure warnings and errors show up. Because the simulation failed the reporting measures didn't run. That is why you are seeing a warnings about "OpenStudio Results measure was not included".

image description

image description

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2018-03-16 16:28:32 -0600

Seen: 523 times

Last updated: Mar 20 '18