Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
3

Zone Report Measure not Working in OS 2.3.0

asked 2017-12-25 04:58:56 -0600

Avi gravatar image

updated 2017-12-25 10:20:07 -0600

After upgrading to OS 2.3.0 it seems that the Zone Report Measure can't anymore collect the data it needs. I think it is something that changed in E+ 8.8.0 but I am not sure what it is. The measure reports the following warnings when run against the test OSM file supplied with it:

Applying ZoneReport
  Result: Success
  Final Condition: Successfully finished writing 'Zone Report'.
  Warn: Could not get data for LightingSummary Entire Facility Interior Lighting Extreme Tstat Zone% Lighting Power Density.
  Warn: Could not get data for EnergyMeters Entire Facility Annual and Peak Values - Gas InteriorEquipment:Gas:Zone:Extreme Tstat Zone Electricity Annual Value.
  Warn: Could not get data for EnergyMeters Entire Facility Annual and Peak Values - Electricity InteriorEquipment:Electricity:Zone:Extreme Tstat Zone Electricity Annual Value.
  Warn: Could not get data for EnergyMeters Entire Facility Annual and Peak Values - Gas InteriorEquipment:Gas:Zone:Extreme Tstat Zone Gas Maximum  Value.
  Warn: Could not get data for EnergyMeters Entire Facility Annual and Peak Values - Gas 
  Warn: Could not get data for ZoneComponentLoadSummary EXTREME TSTAT ZONE Estimated Heating Peak Load Components People Total.
  Warn: Could not get data for ZoneComponentLoadSummary EXTREME TSTAT ZONE Estimated Heating Peak

This is just few random lines from the beginning of a long list of warnings. Any idea what was changed?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-12-28 01:01:27 -0600

Avi gravatar image

updated 2018-01-24 02:55:33 -0600

@Eric Ringold was correct, yet many other items are not being red since there were changes in report tables format. I found out that the measure fails to read the Lighting Power Density since that table is no more indexed by zones. In the new format it is indexed by Load names. Some other HVACSizingSummary items have changed names. Specifically in lines 320,321,322,323,331,332 Zone Cooling/Heating should read Zone Sensible Cooling/Heating. In Lines 331 and 332 Date/Time Of Peak should read Date/Time Of Peak {TIMESTAMP}. In the EnergyMeters each line (lines 345, 349, 354, 358, 362,366) with Timestamp of Maximum should read Timestamp of Maximum {TIMESTAMP} though the entries for Annual and Peak Values - Other had changed and I am not sure which rows replaced the original values (lines 356-366).

Here is a link to my corrected version of the Zone report measure.

edit flag offensive delete link more
2

answered 2017-12-26 14:23:09 -0600

updated 2017-12-26 14:25:29 -0600

The major thing that seems to have changed is the "Zone Component Load Summary" report name now includes spaces, where the measure uses "ZoneComponentLoadSummary" in the queries of the sql file.

I'm not sure when this changed ( @JasonGlazer would know). But if you open the measure file and change all instances of "ZoneComponentLoadSummary" (lines 395, 422, 494, 498, 639 and 660) to "Zone Component Load Summary", the peak load contributions charts will work:

image description

You'll still see some warnings in the stdout, but some of them can be ignored (either the queried values aren't used in the report, or don't exist in that model). I didn't check every one though, so there still might be some malformed queries that should be fixed.

FYI @David Goldwasser

edit flag offensive delete link more

Comments

That change was part of the Checksum enhancement work described in the new feature proposal. The change to the name was a design decision to make it more consistent with other report names (although many other reports still use camel case).

JasonGlazer gravatar imageJasonGlazer ( 2018-01-03 07:06:40 -0600 )edit

Thanks @JasonGlazer!

Eric Ringold gravatar imageEric Ringold ( 2018-01-03 10:47:36 -0600 )edit

@Eric Ringold, thanks for tagging me on this and filing. an issue in measures repo.

David Goldwasser gravatar imageDavid Goldwasser ( 2018-01-23 10:21:52 -0600 )edit

I tried to use the zone report measure from the link in the answer, and continue to to fail the simulation becuase of this measure. The error is No such file or directory @ rb_sysopen - C:/Users/RJH/AppData/Local/Temp/OpenStudioApp.tQ3168/resources/measures/Zone Report/report.html.in C:/Users/RJH/AppData/Local/Temp/OpenStudioApp.tQ3168/resources/measures/Zone Report/measure.rb:617:in initialize' C:/Users/RJH/AppData/Local/Temp/OpenStudioApp.tQ3168/resources/measures/Zone Report/measure.rb:617:inopen' C:/Users/RJH/AppData/Local/Temp/OpenStudioApp.tQ3168/resources/measures/Zone Report/me

hoffmann1320 gravatar imagehoffmann1320 ( 2018-05-25 13:27:43 -0600 )edit

@hoffmann1320 if you're referring to the measure that @Avi linked, the source for your error appears to indicate that you are missing the report.html.in file located in the /resources directory in the measure folder.

Eric Ringold gravatar imageEric Ringold ( 2018-05-25 13:35:31 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

2 followers

Stats

Asked: 2017-12-25 04:58:56 -0600

Seen: 431 times

Last updated: Jan 24 '18