How to make the Controller:OutdoorAir take my EMS controls for reset minimum outdoor air

asked 2017-12-22 18:16:50 -0500

updated 2017-12-23 13:07:32 -0500

I am doing the EMS programming to overwrite the minimum outdoor air flow rate in Controller:OutdoorAir. I give the dynamic schedule through EMS programming, which overwrite the schedule name for "Minimum Outdoor Air Schedule Name". Because there is no actuator to overwrite the minimum outdoor air flow rate. The simulation results show the EnergyPlus take my given schedule. However i need to check the Outdoor Air Ratio (OAR=Actual-Oa-Flow/Minimum-Oa-Flow). If the energyplus "really" take my schedule, my OAR>=1. The fact is not so. (1)I tried the EMS applying point for all possible solutions: InsideHVACSystemIterationLoop, EndofZoneTimeStepsBeforeZoneReport, EndofZoneTimeStepsAfterZoneReport, EndofSystemTimeStepBeforeZoneReport, EndofSystemTimeStepAfterZoneReport. (2)I checked the Input/Output manual, i found the "OA flow rate<=current mixed air flow rate" has more priority than "Apply OA Flow Rate by EMS". (3)i found when my OAR<1, my "OA flow rate"=="current mixed air flow rate". (4)i found when my OAR>=1,my "OA flow rate"<"current mixed air flow rate". (5)i also found the EMS-Application-Guidline, say: there is no guarantee the EMS will work as expected.

This makes me confusing. The EnergyPlus should take whatever i give through the EMS. If the EMS is not working as i expected, what conditions would it be? Anyone can help? Thank you.

edit retag flag offensive close merge delete