Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
5

Why does DCV increase CO2 levels?

asked 2017-11-25 20:57:19 -0500

ADD gravatar image

updated 2021-10-21 13:20:45 -0500

I have a secondary school which needs to be ventilated based on CO2 levels in EnergyPlus V8.8.0. I have tried to use DCV by defining Controller:MechanicalVentilation and ZoneControl:ContaminantController. I have created minimum CO2 concentration schedule name of 500ppm and maximum CO2 concentration schedule name of 1000ppm.

Under normal circumstances, my max CO2 level was around 1800ppm. My purpose was to decrease 1800ppm to 1000ppm by defining DCV, but I am getting seriously higher CO2 levels ( around 6000ppm).

What may be the reason for this problem?

image description The results without DCV

image description

the results with DCV

I have listed Controller:MechanicalVentilation and ZoneControl:ContaminantController objects in below figures.

image description

image description

The CO2 setpoint is 400ppm as dimensionless schedule, CO2 outdoor emission is 400 ppm which I defined as minimum emission, the CO2 indoor emission is 1000 ppm which I defined as maximum emission.

edit retag flag offensive close merge delete

Comments

Could you list the two objects you entered; Controller:MechanicalVentilation and ZoneControl:ContaminantController? and you might want to tag the question E+.

Avi gravatar image Avi  ( 2017-11-26 00:06:00 -0500 )edit

Thanks for your answer. I replied your question as an answer.

ADD gravatar image ADD  ( 2017-11-26 18:03:25 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-11-27 13:25:01 -0500

Avi gravatar image

updated 2017-11-27 14:31:45 -0500

According to the Input Output Reference page 1586 there is only One of the three fileds; Field:Carbon Dioxide Setpoint Schedule Name , Field:Minimum Carbon Dioxide Concentration Schedule Name and Field:Maximum Carbon Dioxide Concentration Schedule Name that should be used when you select System Outdoor Air Method = IndoorAirQualityProcedurein the Controller:MechanicalVentilation object. So the only one that should matter is the Carbon Dioxide Setpoint Schedule , in your case it is the CO2 Setpoint schedule. If I may take a guess I think that you should change the value in the CO2 Setpoint to 0.0004 as it is PPM and your schedule is dimensionless. Or better make Sure there isn't any warning in the eplusout.err file, regarding the DCV.

edit flag offensive delete link more

Comments

1

PPM is dimensionless so the questioner is correct to use: e.g. 400, 1000. If you want to maintain 1000ppm, you will need to use that value for the Carbon Dioxide Setpoint Schedule. But, I suspect you will still have the same problem in your result after making that change. CO2 results indicate less OSA is delivered to the zone when using DCV relative to the base run. I suggest graphing system supply flow and system OSA flow to investigate. Also look at the zone supply flow for both cases.

Molly Curtz gravatar image Molly Curtz  ( 2017-11-28 10:04:02 -0500 )edit

Yes, I had the same problem no matter what I defined for setpoint schedule. I will try to apply your suggestion, too. Thanks to both of you for your responses.

ADD gravatar image ADD  ( 2017-11-28 11:01:59 -0500 )edit

@ADD Are you aware of the example file in the E+ examples folder named : HeatPumpIAQP_DCV.idf? I t seems to be what you are looking for.

Avi gravatar image Avi  ( 2017-11-29 00:50:59 -0500 )edit

I didn't know that , thank you so much

ADD gravatar image ADD  ( 2017-11-29 19:19:59 -0500 )edit

@ADD Please post the correct answer if you succeed.

Avi gravatar image Avi  ( 2017-11-29 23:50:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2017-11-25 20:57:19 -0500

Seen: 331 times

Last updated: Oct 21