Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
1

openstudio-standards apply_prm...efficiency

asked 2017-11-03 17:10:59 -0500

Luke.Y gravatar image

updated 2017-11-04 17:56:39 -0500

I'm trying to call the call the apply_prm_pressure_rise_and_motor_efficiencymethod from openstudio-standards in a measure. I included require-'openstudio-standards'in the measure.

messure snippet:

if sc.to_PumpConstantSpeed.is_initialized 
            pump = sc.to_PumpConstantSpeed.get
            pump.apply_prm_pressure_rise_and_motor_efficiency(chw_pri_only_w_per_gpm,model)

I'm getting the following error (only first line shown):

Optional not initialized :/ruby/2.2.0/gems/openstudio-standards-0.1.15/lib/openstudio-standards/standards/Standards.Pump.rb:26:in `get'

My question is whether I called the method incorrectly or the error lies within the method. If the former, my second question is how to correctly utilize the openstudio-standard methods.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-11-07 16:04:47 -0500

Here's what's going on:

In the code, it assumes that either:

  1. The pump flow rate was autosized and the autosized rated flow rate is available in the SQL file for this pump, which means that a sizing run has been done already.
  2. The pump flow rate was hard sized.

The code needs to be modified to throw a better, more explanatory error when neither of these conditions are met.

You can run a sizing run using OpenStudio-Standards in your measure via:

model.runSizingRun()

edit flag offensive delete link more

Comments

Thanks @aparker. That makes sense.

Luke.Y gravatar image Luke.Y  ( 2017-11-07 16:11:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2017-11-03 17:10:59 -0500

Seen: 118 times

Last updated: Nov 07 '17